Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've been struggling a while with getting the iMON LCD/IR-receiver on my Antec Fusion Black case to shutdown together with the system (XBMC Live 10 - ubuntu based). But it won't. When it's turned off the LCD still lights up the whole room. Many have proposed the "solution" of setting the machine into hibernation instead but that however won't work for me, since I'm unable to suspend my system.

It is the LCD/IR-module that prevents me from suspending and I haven't found a solution to properly unload it on suspending (it's way above my linux knowledge). I need help with getting the display to turn off the backlight when the system is turned off. Can anyone please help me?

If anyone also has the knowledge on how to get the eject function to work on my Antec Veris rm200 remote I would be very grateful, I was told about that it could get fixed with irexec but I do not know how since I haven't been able to find a good tutorial on the subject.

Thank you for helping me!

share|improve this question
    
You may get better answers on Superuser as this is a hardware problem. Check motherboard or BIOS how to disable USB standby power supply. –  Takkat Mar 9 '11 at 7:26
    
The thing is that I cannot turn off the power supply for LCD/IR-receiver because then I cannot boot the htpc with my remote control. What I want is for the backlight to go off on the display. –  Niklas Mar 9 '11 at 9:22
    
That can't be done unless there is a feature on how to control backlight brightness - is there? –  Takkat Mar 9 '11 at 10:01
    
I don't think so, but when I try to suspend the screen goes black the lights up again so apparently something in the suspend script turn offs the lcd but won't completely go into suspend mode. Where can I see what is unloaded during suspend? –  Niklas Mar 9 '11 at 11:34
1  
I think I've managed to get it working (kinda). I read that it is a bug with USB3.0 that has been fixed in the Natty release but has not been included in Maverick. What I need to do was to add the line SUSPEND_MODULES="xhci" to the file /etc/pm/config.d/unload_module and then it suspended ergo the LCD is also black. I think I will settle with that if not anyone has a better solution :) –  Niklas Mar 9 '11 at 11:44

1 Answer 1

up vote 0 down vote accepted

solution copied from comment:

I think I've managed to get it working (kinda). I read that it is a bug with USB3.0 that has been fixed in the Natty release but has not been included in Maverick. What I needed to do was to add the line SUSPEND_MODULES="xhci" to the file /etc/pm/config.d/unload_module and then it suspended, ergo the LCD is also black. I think I will settle with that if not anyone has a better solution :)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.