Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My question is related to Ubuntu tells me I have packages to upgrade when I don't, which pertains to Ubuntu 10.04. But my problem is with Ubuntu 12.04.2LTS (and the solutions mentioned for 10.04 do not work).

Based on what I learned from that question, and related questions on ServerFault (also with unhelpful answers), I have tried running /usr/lib/update-notifier/apt-check --human-readable, but it returns wrong information (the same information which gets added automatically to /etc/motd and displayed at every login via ssh):

6 packages can be updated.
6 updates are security updates.

Just today I ran sudo apt-get update && sudo apt-get upgrade and there was one regular update available (plus 3 kernel packages, which were held back). But my update and upgrade did not change the output of apt-check. I have been having this problem for a while and just decided to look into it today.

For 10.04, I have seen fixes related to /etc/motd.tail, but no such file exists on my system.

share|improve this question

2 Answers 2

Clear the package cache and download it again:

sudo dpkg --clear-avail

sudo apt-get update

If it doesn't solve the problem, create an empty motd.tail:

sudo touch /etc/motd.tail

share|improve this answer
1  
Thanks for the ideas, but I figured it out. Nothing was broken; it was just a case of confusing/misleading messages. –  Eric Lambart May 18 '13 at 19:17
up vote 1 down vote accepted

Well, it turns out the apt-check message was correct. But the apt-get upgrade message was misleading. It said:

The following packages have been kept back:
  linux-headers-server linux-image-server linux-server
0 upgraded, 0 newly installed, 0 to remove and 3 not upgraded.

This naturally leads one to believe that there are only 3 packages which could potentially be downloaded and installed/upgrade.

But when I did sudo apt-get install linux-server (the only way I know to get past the 'kept back' status on upgrade), it said: 3 upgraded, 3 newly installed, 0 to remove and 0 not upgraded.

That's right, 3 + 3 = 6 packages, just like apt-check said! And after the install/upgrade, a fresh login shows no available updates.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.