Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have four nodes in the "Ready" state, and I am still getting the following error when trying to bootstrap:

ERROR No matching node is available.

The server is running 13.04 with Juju 0.7.

I have been walking through the instructions on the MAAS site:

I also tried following the instructions to install the latest version of Juju (1.10.x) as described on, but then I ran into some other errors, including "error: no tools available" when trying to bootstrap and "use of closed network connection" when trying to sync-tools.

How can I get a simple MAAS + Juju setup going for testing?

share|improve this question

You may have hit bug 1064291. This occurs if you have machines that aren't amd64 or have less than 512M of memory. The workaround is to bootstrap with constraints turned off:

juju bootstrap --constraints "arch=any mem=0"

If this works for you, please mark the bug as "affects me too".

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.