Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I was running a ubuntu 13.04 instance on ec2. I have juju .7 installed and bootstrapped. when I tried to deploy lamp, it caused the instance to terminate.

ubuntu@ip-10-62-73-113:~$ juju status
2013-05-15 22:11:58,102 INFO Connecting to environment...
2013-05-15 22:11:58,877 INFO Connected to environment.
machines:
  0:
    agent-state: running
    dns-name: ec2-54-224-187-196.compute-1.amazonaws.com
    instance-id: i-e26f328a
    instance-state: running
services: {}
2013-05-15 22:11:59,090 INFO 'status' command finished successfully
ubuntu@ip-10-62-73-113:~$ juju -v deploy lamp
2013-05-15 22:12:13,951 DEBUG Initializing juju deploy runtime
2013-05-15 22:12:13,952 INFO Searching for charm cs:precise/lamp in charm store
2013-05-15 22:12:15,054 INFO Connecting to environment...
2013-05-15 22:12:15,157 DEBUG Connecting to environment using ec2-54-224-187-196.compute-1.amazonaws.com...
2013-05-15 22:12:15,158 DEBUG Spawning SSH process with remote_user="ubuntu" remote_host="ec2-54-224-187-196.compute-1.amazonaws.com" remote_port="2181" local_port="45900".
2013-05-15 22:12:15,673:2914(0x7f1c746e6740):ZOO_INFO@log_env@712: Client environment:zookeeper.version=zookeeper C client 3.4.5
2013-05-15 22:12:15,673:2914(0x7f1c746e6740):ZOO_INFO@log_env@716: Client environment:host.name=ip-10-62-73-113
2013-05-15 22:12:15,673:2914(0x7f1c746e6740):ZOO_INFO@log_env@723: Client environment:os.name=Linux
2013-05-15 22:12:15,673:2914(0x7f1c746e6740):ZOO_INFO@log_env@724: Client environment:os.arch=3.8.0-19-generic
2013-05-15 22:12:15,674:2914(0x7f1c746e6740):ZOO_INFO@log_env@725: Client environment:os.version=#29-Ubuntu SMP Wed Apr 17 18:16:28 UTC 2013
2013-05-15 22:12:15,674:2914(0x7f1c746e6740):ZOO_INFO@log_env@733: Client environment:user.name=ubuntu
2013-05-15 22:12:15,675:2914(0x7f1c746e6740):ZOO_INFO@log_env@741: Client environment:user.home=/home/ubuntu
2013-05-15 22:12:15,675:2914(0x7f1c746e6740):ZOO_INFO@log_env@753: Client environment:user.dir=/home/ubuntu
2013-05-15 22:12:15,675:2914(0x7f1c746e6740):ZOO_INFO@zookeeper_init@786: Initiating client connection, host=localhost:45900 sessionTimeout=30000 watcher=0x7f1c731f3850 sessionId=0 sessionPasswd=<null> context=0x294a6f0 flags=0
2013-05-15 22:12:15,676:2914(0x7f1c6ee90700):ZOO_INFO@check_events@1703: initiated connection to server [127.0.0.1:45900]
2013-05-15 22:12:16,215:2914(0x7f1c6ee90700):ZOO_INFO@check_events@1750: session establishment complete on server [127.0.0.1:45900], sessionId=0x13eaa3f9e660004, negotiated timeout=30000
2013-05-15 22:12:16,218 DEBUG Environment is initialized.
2013-05-15 22:12:16,219 INFO Connected to environment.
2013-05-15 22:12:16,544 INFO Charm deployed as service: 'lamp'
2013-05-15 22:12:16,544:2914(0x7f1c746e6740):ZOO_INFO@zookeeper_close@2505: Closing zookeeper sessionId=0x13eaa3f9e660004 to [127.0.0.1:45900]

2013-05-15 22:12:16,546 INFO 'deploy' command finished successfully
ubuntu@ip-10-62-73-113:~$ 
Broadcast message from root@ip-10-62-73-113
    (unknown) at 22:12 ...

The system is going down for power off NOW!
Connection to ec2-184-73-114-174.compute-1.amazonaws.com closed by remote host.
Connection to ec2-184-73-114-174.compute-1.amazonaws.com closed.

This happened twice in a row, so it doesn't seem like some freak accident.

share|improve this question

1 Answer 1

Solved it. If anyone else has the problem:

I was putting the first instance, (the one I ran juju bootstrap on) in the same security group as all the instances juju creates.

When I found this: https://bugs.launchpad.net/juju/+bug/1161906 which describes how juju cleans up "orphaned" instances. Since my master instance was in the security group for the created instance, juju thought it was orphaned.

tl;dr: don't have your first instance in the same security group as the created instances.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.