Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Attempting to convert .ISO to .IMG for USB install, here is the line of code: hdiutil convert -format UDRW -o ~/ubuntu-13.04-desktop-i386.img ~/ubuntu-13.04-desktop-i386.iso. After trying to execute the command terminal says "No such file or directory".

So I don't know what I'm doing wrong, is there a space where it shouldn't be or do I have something backwards, I don't know, I just need some help, so I can make this USB install work.

share|improve this question
    
You should not have typed in what (any of us) are suggesting exactly as we state. You should be filling in the 'explicitpath' and 'path/to/filename' parts with what YOU know those parts to be. That's the problem, I think. If you aren't familiar with how to find the explicit path to a filename, we can help there instead. –  gravity May 15 '13 at 14:40

3 Answers 3

In short: "Where is the file you saved at?"


A few things to try/consider:

  1. The "~/" portion of your question assumes that the file exists in your main /home/ folder for your user. Where (exactly) is the file located?

  2. Have you tried... hdiutil convert /ubuntu-13.04-desktop-i386.img -format UDRW -o /ubuntu-13.04-desktop-i386.iso instead?

It sounds like you're just not finding the file wherever it was that you saved it, originally... hence, "no such file or directory," and it's unlikely located in your main home/top folder. It's probably in ~/downloads/ or something like that.

share|improve this answer
    
Have not tried "hdiutil convert /explicitpath/ubuntu-13.04-desktop-i386.img -format UDRW -o /explicitpath/ubuntu-13.04-desktop-i386.iso", but I will. I moved the file, it''s located on the top of Macintosh HD, the same place as the Users file and Applications file. –  gherni May 15 '13 at 14:28
    
Tried your code suggestion, unfortunately it didn't work, thank you though. –  gherni May 15 '13 at 14:36
    
Wait.. why is the file "at the top of your Mac HD"? Please state, explicitly, the /path/to/the/filename.ext. Do you understand what we are asking for you to provide? If not, please say so, and I'll provide some help in that vein instead. –  gravity May 15 '13 at 14:37
    
When I right click the file and choose the "get info" option under where it says, Where:/, I'm hoping that helps, if not maybe I don't understand what you asking and that probably where my problem is. –  gherni May 15 '13 at 14:52
    
So, then, the correct syntax would be in my re-edited answer above. Try again, using the new code. –  gravity May 15 '13 at 14:58

Just press Ctrl+Alt+T on your keyboard to open Terminal. When it opens, run the command(s) below:

sudo hdiutil convert -format UDRW -o /path/to/file.img /path/to/file.iso
share|improve this answer
    
Used the "sudo" command and it asked for the password and of course the previous owner didn't not know it, so going to run system restore and get admin control and attempt again to see if the "sudo"command works, fingers crossed. Thank you. –  gherni May 15 '13 at 15:31
    
The syntax in this answer is wrong and will throw up an error with "No such file or directory." –  cksum Dec 10 '13 at 1:05
    
@cksum The syntax is right, you just have to make sure the path is correct. I've used it many times. –  Mitch Dec 10 '13 at 4:36
    
@Mitch That's strange because I tried it and it gave me the error in the original question. I references Ubuntu's official guide on converting an image and they use the syntax I put in my answer. That one worked no problem. Using your method always resulted in an error even though the path to the file was correct. –  cksum Dec 10 '13 at 8:32

Misplaced order

You may misplaced the order of the files.


I do not have encoutered this problem so I am not sure that's the problem.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.