Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Just install 13.04 and am having trouble setting up online accounts with facebook. It opens up firefox and when I log in it comes up with a security warning. Any ideas why this is or what I could do to fix it?

share|improve this question
    
I guess this is an issue in Facebook's authentication and authorization services since other user report similar issues: askubuntu.com/questions/295644/… –  LiveWireBT May 15 '13 at 14:07
    
Some users have suggested that disabling some of Facebook's "Secure Connection" settings within their accounts directly through Facebook has resolved a lot of the 3rd-party apps and API calls that have failed lately. Worth a shot. –  gravity May 15 '13 at 15:23
    
Thanks, already gave that a go but it didn't make a difference unfortunately. –  mark howard May 15 '13 at 17:08
    
I'm having this problem and I'm not even trying to connect to Facebook. It seems to be happening when I launch Skype. –  Andy E May 15 '13 at 18:50
    
Not sure exactly why this worked but I eventually got it working. here are the steps: 1. disable secure connection on facebook security preferences, 2. remove the ubuntu app from your facebook apps page if it is there, 3. sign out of facebook, 4. open online account and add a facebook account. Firefox should open as before, but then go back to the online accounts page, right click in the space where the page usually loads and select reload. Should work from there. Random! –  mark howard May 16 '13 at 2:19

2 Answers 2

There's a bug filed for this issue: https://bugs.launchpad.net/bugs/1180297

The root cause is that Facebook redirects to an insecure HTTP page during the authentication process, and for security reasons we don't allow that. The same problem appeared in February, and then Facebook was quick to fix it in a few days. Now it seems it's taking longer, but I'm still hopeful.

share|improve this answer
    
Thanks so much for this. I managed to get connected with my work around but it drops the connections now and again, which I guess must be related. –  mark howard May 21 '13 at 13:08

the temporary solution for this as on launchpad page is to add the lines

<setting name="AllowedSchemes" type="as">['https','http']</setting>

to the file /usr/share/accounts/providers/facebook.provider

but it has got security risks.

share|improve this answer
    
I did this just to set it up, and then removed the line. –  Bryan Agee Jun 4 '13 at 17:59
    
That does not make difference in the problem of security risks. Also even after connecting you will some times recieve a notification that Failed to connect to <facebook account> error. Facebook has got issues with external messengers, hope they sort it out soon. –  meteors Jun 5 '13 at 9:41
    
The only difference it makes is that I know when it is connecting insecurely. I can minimize exposure for the one brief connection to authenticate, and then disallow it from using http (w/o ssl) when I'm on a public network. There are still risks, but they are smaller and calculated. –  Bryan Agee Jun 6 '13 at 4:21

protected by Community May 15 '13 at 18:55

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.