Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

A few seconds after login my window decorations disappear and I have a black desktop background.

I installed the latest catalyst drivers. 13.4. I have an HD7880.

I Tried:

gtk-window-decorator --replace

unity --reset

reinstalling drivers.

how to debug / fix this.

share|improve this question

1 Answer 1

I'm running with a Radeon HD 6400M, and 13.04 seems to really not like the updated graphics drivers (or at least, that's the conclusion I've come to). After installing them I had exactly the same issue.

For me, the following worked:

sudo apt-get purge fglrx

followed by (possibly after a reboot, I can't quite remember. Probably do one just to be sure)

gsettings reset org.compiz.core:/org/compiz/profiles/unity/plugins/core/ active-plugins

The latter command seemed to take quite a long time to run, but once it had everything worked fine thereafter. Hope this helps.

share|improve this answer
    
You have to reboot after installing or removing the proprietary drivers (ati and nvidia) as they are loaded in the initrd –  bodhi.zazen May 15 '13 at 17:47

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.