Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am trying to install Ubuntu 12.04.2 alongside Windows 7 on a new Samsung 840 SSD.

I have tried the installation twice from scratch, but the same thing happened twice: windows works fine, then I install Ubuntu, then I can't boot any more.
The first time, the screen was black and just showed "> grub", I think.
The second time (after formatting the whole SSD again with windows, reinstalling windows, then installing Ubuntu again) a similar, but not the same problem: now it shows "error: file not found", and then in the next line "> grub recovery", or similar.

I tried boot-repair, without effect.

Boot-repair generated the following report: Boot Info Script.

Any help is highly appreciated! Thanks, Stephen

PS I also tried once the "erase all and install only ubuntu" option. Also then I could not boot.


UPDATE: ok, the weirdest thing just happened: I tried to restore the windows MBR, so that I could at least boot into windows and get some work done. But by accident I chose to boot from HDD instead - and ubuntu worked. After some tests I would say, that in 10 percent of boots attempts, grub does indeed seem to work. On most attempts I do get the "no file found error". I assume this can only be due to a hard drive error??

UPDATE: Thanks very much for your suggestions! Unfortunately, I don't think this is the solution for my situation. I am trying to install windows 7 plus Ubuntu, on a three year old Dell Latitude E6510, with a normal BIOS. Also, the problem persists even if try to only install Ubuntu. I have a feeling that I may have made a stupid mistake during my first try to install the system - the power cable was not inserted and windows installation got stuck, and a few other weird things happened when I tried to install ubuntu with the "something else" option. Perhaps I somehow damaged the drive in a way that is not repaired when I just format the drive and create a new partition table? Still windows resumed the installation after I inserted the power cable and windows has worked on both installation attempts.

Thanks in advance! Stephen

PS I tried to put this post as a comment to Dschinns answer, but the comment option is not shown for me...

share|improve this question
    
after you tried already to repair grub - I think it is uefi-related resp. depending if you choose simply efi-related installation ? here is a link (in German) which describes a similiar attempt of installation with windows 8 - I assume you installed windows 8 ? martinwpunkt.de/dual-boot-windows-8-und-ubuntu-teil-2 does this help ? here is else posting about uefi : askubuntu.com/questions/78582/… –  dschinn1001 May 15 '13 at 13:54
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.