Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I would like to share a solution to a problem i've managed to reproduce on two systems with two different setups, the first setup (Will be refered to as A) was an nvidia optimus setup with ubuntu 13.04 x64. The second setup (Will be referred to as B) Was just an nvidia card with ubuntu 12.10 x64.

Issues encountered on A were; 1] Games force closing when starting up (EG Loading screens) 2] Games not running on the nvidia card, or lagging.

Issues encountered on B were; 1] Games force closing when starting up.

share|improve this question

closed as off-topic by bain, Eric Carvalho, Vojtech Trefny, mikewhatever, bodhi.zazen Jun 27 at 16:30

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Bug reports and problems with the development version of Ubuntu should be reported on Launchpad so that developers can see, track and fix these issues." – bain, Eric Carvalho, Vojtech Trefny, mikewhatever
If this question can be reworded to fit the rules in the help center, please edit the question.

1 Answer 1

The solutions;

A 1] Right click your game's properties on the steam client and untick access steam community in game.

A 2] With bumblebee installed, firstly make steam start as optirun. Eg: Add a startup program with the command optirun steam (No capitals) and then make shortcuts to your games on your desktop, this can be achieved by right clicking the game on steam and clicking "create desktop icon" once the icon for the game has been made, right click it, go properties, and at "Command" add optirun before the command. This cannot be done as a "Custom launch command" Eg: -optirun or optirun, they just don't seem to work. The finished command should be something like optirun steam steam://rungameid/225260 but with a different ID obviously.

B 1] Right click your game's properties on the steam client and untick access steam community in game.

share|improve this answer
    
unable to accept as answer for two days. but this is the solution. –  Lemagex May 15 '13 at 7:09

Not the answer you're looking for? Browse other questions tagged or ask your own question.