Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Please help me resolve this issue. I am trying to install a Perl module Set::IntervalTree in Ubuntu. I am repeatedly receiving the following error:

cpan[1]> install Set::IntervalTree
CPAN: Storable loaded ok (v2.20)
Going to read '/root/.cpan/Metadata'
  Database was generated on Tue, 14 May 2013 05:29:04 GMT
Running install for module 'Set::IntervalTree'
CPAN: YAML loaded ok (v0.84)
Running make for B/BE/BENBOOTH/Set-IntervalTree-0.07.tar.gz
CPAN: Digest::SHA loaded ok (v5.47)
CPAN: Compress::Zlib loaded ok (v2.02)
Checksum for /root/.cpan/sources/authors/id/B/BE/BENBOOTH/Set-IntervalTree-0.07.tar.gz ok
Scanning cache /root/.cpan/build for sizes
............................................................................DONE
CPAN: Archive::Tar loaded ok (v1.52)
Set-IntervalTree-0.07/
Set-IntervalTree-0.07/src/
Set-IntervalTree-0.07/lib/
Set-IntervalTree-0.07/Changes
Set-IntervalTree-0.07/MANIFEST
Set-IntervalTree-0.07/t/
Set-IntervalTree-0.07/typemap
Set-IntervalTree-0.07/perlobject.map
Set-IntervalTree-0.07/IntervalTree.xs
Set-IntervalTree-0.07/Makefile.PL
Set-IntervalTree-0.07/README
Set-IntervalTree-0.07/META.yml
Set-IntervalTree-0.07/META.json
Set-IntervalTree-0.07/t/Set-IntervalTree.t
Set-IntervalTree-0.07/lib/Set/
Set-IntervalTree-0.07/lib/Set/IntervalTree.pm
Set-IntervalTree-0.07/src/Makefile
Set-IntervalTree-0.07/src/interval_tree.h
Set-IntervalTree-0.07/src/test_main.cc
CPAN: File::Temp loaded ok (v0.22)

  CPAN.pm: Going to build B/BE/BENBOOTH/Set-IntervalTree-0.07.tar.gz

Checking if your kit is complete...
Looks good
Writing Makefile for Set::IntervalTree
Writing MYMETA.yml and MYMETA.json
cp lib/Set/IntervalTree.pm blib/lib/Set/IntervalTree.pm
AutoSplitting blib/lib/Set/IntervalTree.pm (blib/lib/auto/Set/IntervalTree)
/usr/bin/perl /usr/share/perl/5.10/ExtUtils/xsubpp  -C++ -typemap /usr/share/perl/5.10/ExtUtils/typemap -typemap perlobject.map -typemap typemap  IntervalTree.xs > IntervalTree.xsc && mv IntervalTree.xsc IntervalTree.c
c++ -c  -Isrc -D_REENTRANT -D_GNU_SOURCE -DDEBIAN -fno-strict-aliasing -pipe -fstack-protector -I/usr/local/include -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -g -O2   -DVERSION=\"0.07\" -DXS_VERSION=\"0.07\" -fPIC "-I/usr/lib/perl/5.10/CORE"  -Isrc IntervalTree.c
/bin/sh: c++: not found
make: *** [IntervalTree.o] Error 127
  BENBOOTH/Set-IntervalTree-0.07.tar.gz
  /usr/bin/make -- NOT OK
Running make test
  Can't test without successful make
Running make install
  Make had returned bad status, install seems impossible
Failed during this command:
 BENBOOTH/Set-IntervalTree-0.07.tar.gz        : make NO

cpan[2]> 
share|improve this question

1 Answer 1

Look at this part of the error message:

c++: not found

If you type the command that fails, ubuntu tells you what package provides it:

$ c++

The program 'c++' can be found in the following packages:
 - g++
 - clang

Type this to install it: sudo apt-get install g++

Hope this helps

share|improve this answer
    
Dear Francesc Guasch, I have gone it. It seems, the library is already installed and updated. It says, that the compiler is to its newest version –  user132891 May 15 '13 at 11:09
    
Dear Francesc Guasch, Thank you. I tried again. And it is working now.. Than you very much –  user132891 May 16 '13 at 6:17

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.