Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am new to Linux and I have an issue I have installed Lubuntu which I plan to use as a headless server so I need to be able to remote desktop into it however after installing

sudo apt-get install xrdp 

and then using windows remote desktop connection in windows 8 I get the following screen after logging in using sesman-Xvnc

enter image description here

how can I get this so I can see the desktop normally I would just use Teamviewer but Iwant something I can use on my LAN and also I cannot set Teamviewer to start on boot like I can in windows

finally I did get it working using vino and Tightvnc on windows but before I would connect it kept asking on the Lubuntu screen to allow or deny someone accessing your computer is there a way to get this to auto-accept so i don't have to accept on the other end this being the headless Lubuntu server

share|improve this question
    
If you open the Desktop Sharing Preference app, you can configure it to allow access without requiring a password. Do not mark the "Automatically configure UPnP router.." option. RDC/VNC clients should then have no problem connecting. –  douggro May 15 '13 at 7:02

1 Answer 1

It is possible to set vino to allow connections without confirmation. On the headless server, open a terminal and type the command

vino-preferences

Remove the check besides

You must confirm each access to this machine

enter image description here

Note: the dialog box in this screen capture is NOT configured correctly for your case, I include it only to show what the dialog box looks like.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.