Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have always run the program UFW as my firewall in Ubuntu, and been satisifed with its performance. When I installed Ubuntu 13.04, and enabled ufw, I was not able to access the internet, and all ports were blocked. This isn't the behaviour I was expecting. I expect to reject all unsolicited packets, but allow ones requested by my computer.

The way UFW functioned in ubuntu 10.04 I found to be satisfactory (as an example). I don't want to have to add a port 80 exception to access the internet, nor do i want port 80 open and responding to port-scans. How can I make ufw drop unsolicited packets, but accept packets requested by my computer?

I am using kernel 3.8 raring ringtail, and mate Desktop 1.6.

share|improve this question
    
what commands did you run ? Post the output of sudo ufw status verbose. I am not sure you fully understand firewalls and ports, but when you use a client, such as firefox, it uses a random high port on your computer to connect to port 80 or 443 on the remote server. If you want fine control over packet you will need to learn iptables, good news is that the syntax of iptables is similar to ufw ;) –  bodhi.zazen May 15 '13 at 4:01
    
###Desktop Not working 12.04 or later### s@x:~$ sudo ufw status verbose Status: active Logging: on (low) Default: deny (incoming), allow (outgoing) New profiles: skip ##Working, on an 10.04 server J@$ sudo ufw status verbose Status: active Logging: on (low) Default: deny (incoming), allow (outgoing) New profiles: skip –  j0h Jun 10 '13 at 21:06
    
Looks as if you have no rules to allow any incoming connections on either server. Hard to know if it is a problem with DNS, routing, or your firewall settings. –  bodhi.zazen Jun 10 '13 at 21:09
    
I have some port exceptions, I dont want to list them though. With, or without exceptions, ufw, in 10.04 Ubuntu, works as I would expect. maybe its a version issue? ufw on lucid is 0.32, on 12.04, its version 0.33. –  j0h Jun 10 '13 at 21:42
1  
Well, order of your rules is important and if you do not list them, it will be difficult to impossible for us to provide assistance. –  bodhi.zazen Jun 10 '13 at 21:49

2 Answers 2

The ufw firewall is implicating with the iptables.

So you could add some rules in iptables and with that you enfluence the "behaviour" of ufw.

Here is a description of how to add rules to iptables:

http://blog.jwilford.co.uk/post/33238674122/using-a-custom-chain-to-define-a-list-of-trusted-hosts

( In ufw there is parameter resp. rule "limit" but it is only supporting IPv 4. To edit iptables would bypass the restrictions of ufw. )

( I write this answer 2nd time - because the first attempt was deleted by moderator by an oversight, before I could complete it with my additions. )

share|improve this answer

For me, The solution was to recompile the ufw version source code.

"sudo chmod -R g-w /etc/ufw " from the comments was useful to help get rid of the warnings. After recompiling, I have a functional firewall, and IPV4/6 support now.

I am REALLY curious why more people do not have this issue, I've had this problem on every install of Ubuntu 12.04 or later. Guys aren't turning on your firewalls of something?

UFW source from: https://launchpad.net/ubuntu/+source/ufw

share|improve this answer
    
This is a good possibility too. Me was thinking that you wanted to deny weird traffic. - So I thought about simply - if you know for sure, that you visit certain places in the web - define a list of trusted hosts in iptables. This would have been adopted by ufw. True: This is a bit humblesome. –  dschinn1001 Jun 18 '13 at 19:07

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.