Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am facing an issue when I did following. Initially my pc had Windows 7 ultimate x64 installed. Then I made it dual boot with Ubuntu 12.04 x64. Everything used to work fine then.

Problem started when I upgraded Windows 7 to Windows 8 pro. After my upgrade I list grub loader. I was not getting any option to select OS. Then I googled the issue and somehow I do not remember exactly how, I fixed that issue. I am now getting OS option at boot time.

However sometimes usually after installing any updates in Ubuntu I do not see grub loader at boot. Sometimes it appears sometime is does not. I have figured out that this usually happens after Ubuntu update. To fix that issue I run boot-repair and repair system with recommended button. This solves the issue temporarily until Ubuntu update.

By ubuntu update I do not mean Ubuntu version upgrade, update means the security fixes and kind of stuff.

My recent boot repair log can be found at:

I am not that much technically familiar with linux machines so any advice will be appreciated.

share|improve this question
Does it happen after any package update or just kernel updates? By the way, you have lots of kernels installed, it's fine to remove the older ones. – grimpitch May 15 '13 at 2:29
@grimpitch thanks, i will find a way to delete older kernels – Calvin May 15 '13 at 9:09
@grimpitch: hi i tried to clean kernels using cleanup scripts but no luck, can you suggest me a way to do that... – Calvin Jun 2 '13 at 15:04
up vote 1 down vote accepted
  1. Via Windows tools, reduce your Windows partition from 75 to 74GB
  2. Create a separate /boot partition in the 1GB free space as follow:
share|improve this answer
hi i tried to follow the steps mention in the given link but even after repeated tries i am unable to select the new created 1 G partition from boot-repair, any thoughts??? – Calvin Jun 2 '13 at 15:03
What is the URL provided by Boot-Repair? – LovinBuntu Jun 2 '13 at 22:31
hi, i formatted newly created drive with ext4 fs, then it was visible and I successfully relocated Grub loader. It also cleared old kernels :) that worked it seems, thanks – Calvin Jun 3 '13 at 4:36

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.