Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've installed bumblebee with this tutorial http://eternalvoid.net/tutorials/linux-optimus-gt650m/

and when I try optirun i've got black screen & this:

$ optirun glxspheres
Polygons in scene: 62464
Visual ID of window: 0x21
Xlib:  extension "NV-GLX" missing on display ":8".
[VGL] WARNING: The OpenGL rendering context obtained on X display
[VGL]    :8 is indirect, which may cause performance to suffer.
[VGL]    If :8 is a local X display, then the framebuffer device
[VGL]    permissions may be set incorrectly.
Context is Indirect
OpenGL Renderer: Gallium 0.4 on llvmpipe (LLVM 0x301)
[VGL] ERROR: OpenGL error 0x0500
[VGL] ERROR: in readpixels--
[VGL]    310: Could not Read Pixels

Lenovo y580, Ubuntu 12.04 x64, NVIDIA ver.driver 319.17

It's a problem with driver, configuration or something else?

share|improve this question
    
Does that also happen, if you run sudo optirun glxspheres? –  cuichi Mar 22 at 19:24

1 Answer 1

I GUESS, it is a problem with the nvidia driver. Reading the link you posted, on how you installed bumblebee, I see that you installed the nvidia driver manually. My suggestion is to change runlevel by pressing:

STRG + ALT + f6

then stop the window-manager

sudo stop lightdm

and uninstall the nvidia driver

sudo apt-get remove --purge nvidia

Since you have already added the swat-x-repos, you should then be able after restarting to install nvidia again from the repositories following step 1 and 2 again and then typing

sudo apt-get install nvidia-331 bumblebee-nvidia

Hope that helps.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.