Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I use Places > Connect to Server... to connect to a Windows share in my work environment (requires Kerberos authentication). When I do so, I can access the Windows share via Nautilus, but I can't figure out how to access the share from the command line without using smbclient.

For example, the share isn't mounted under /mnt or /media. I also looked into ~/.gvfs but that's empty as well.

Is it possible to access the mounted Windows share from the command line without using smbclient?

share|improve this question
add comment

3 Answers

You can use:

mount -t smbfs //servername/myshare /mnt/servername/myshare -o username=myself

If it doesn't work, try cifs instead of smbfs, aparently cifs works for newer Windows servers, but I've never had to use it.

Where //servername/myshare is the share address, and /mnt/servername/myshare is the mount folder in your system.

Once it's mounted you can access the share at /mnt/servername/myshare via command line.

I found the solution in this Ubuntu Forums: smbclient works, mount -t smbfs doesn't

share|improve this answer
    
CIFS for me had other advantages, too. But it's possible the underlying problems were solved meanwhile. If a share was disconnected due to lost network connectivity, CIFS for me always restored it to the old state (once network was back), while the traditional smbfs left a broken mount behind, which had to be forcefully unmounted and then mounted again ... but take that with a pinch of salt, it's possible that this was solved. –  0xC0000022L Mar 9 '11 at 0:06
    
I think it has something to do with the fact that the environment I'm in uses Kerberos authentication. If I remember correctly, I tried using both the smbfs and cifs mount commands before, but neither of them supported krb5 (maybe that's changed now...). If I mount the remote drive using the GUI, it only works when I've initialized a Kerberos key with kinit. If the output of klist is empty, the GUI won't work either. I'll try some things later when I'm on the right network and post my findings here. Thanks! –  Bryan Mar 9 '11 at 14:28
    
I've confirmed that smbfs and cifs still do not support krb5. I've also confirmed that even though the GUI method requires both an active Kerberos ticket and my Kerberos password. If I try it without a Kerberos ticket it will still prompt me for my password but will not mount the share. So if smbfs and cifs still don't support krb5, then what is the GUI using?! –  Bryan Mar 17 '11 at 16:18
1  
FWIW "smbfs" has become an alias for "cifs" on newer versions of Ubuntu. –  jelmer Mar 26 '11 at 19:45
add comment

The GVFS mount point has changed from one release to the next. On Ubuntu 12.10, it's at /var/run/<username>/<mountname>/.

One way to easily find the path of the mount is by using the "Open Terminal" plug-in.

Install via the software center

You'll need to log out and in for to complete the installation.

Once installed, navigate to the Windows Share folder, click "File", and then "Open in Terminal".

Another way to find the mount is to examine the output of mount. Look for the line that begins with gvfsd-fuse.

share|improve this answer
    
Thanks @Flimm, I'll try this out ASAP and report back. –  Bryan Nov 25 '12 at 0:29
add comment

Go to your home directory, by running: cd ~

Then run: ls .* to list files and directories in it that start with ..

This will show you all the hidden directories and config files in your home directory.

Look for the .gvfs direcrory. You can go into it with cd .gvfs.

That will have all the mount points that you made inside the OS GUI.

And you can brows the mounted drives or shares from these points.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.