Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I downloaded wubi installer for 12.04 LTS (64-bit) after deciding to re install Ubuntu, but every time I try it freezes on expanding. i have also tried using a bootable USB but after I choose install within windows it restarts and doesn't install. Is my computer not compatible or am I missing something.

p.s. I know there is already questions like this asked but I already exhausted their advice too.

envy 6-1040ca, windows 7 64bit

Specs (double checked):


Edit: I did run chkdsk and no diffrence

share|improve this question
up vote 0 down vote accepted

The reason you only get "Install inside Windows" and then it reboots is this: Why don't I have the option ''Install Ubuntu alongside with them''

What you can do about it is this: My laptop already has 4 primary partitions: how can I install Ubuntu?

Why Wubi is freezing on expanding the image? I don't know, but if you want Wubi then you will have to provide the output of the Wubi log from the %temp% directory i.e. wubi-12.04.2-rev272.log. Also I recommend running chkdsk /f first and possibly defragmenting. If it worked before and stopped working then there could be some NTFS filesystem corruptiong that is causing problems.

After reviewing your log file, the only thing I can guess is that it's tripping over the space in your Windows user name. I've already seen cases where an apostrophe causes issues, but there's no diagnostic output in your case that shows why it is failing. I will take a look at the code to see.

You can do one of two things:

  1. Run it under a different windows account where the user name doesn't have a space
  2. Run Wubi with the 12.04.2 desktop ISO. This doesn't use the diskimage and doesn't need to expand anything so likely won't be affected. Note that to do this, you'll have to save the 12.04.2 desktop ISO in the same folder as Wubi, but you need to use a patched wubi (see Is there wubi.exe that can support ubuntu-12.04.2-desktop-amd64?

Either way, remember to use nomodeset to boot.

share|improve this answer
K, Sorry about that I haven't used Ask Ubuntu before. – Alex B May 14 '13 at 20:35
@AlexB no worries. I'm going to delete my comment now and you can do the same as it doesn't add value anymore. Also, I updated my answer for what I think may be happening – bcbc May 14 '13 at 21:20
the "wubi-r273-signed.exe" worked. I had tried to use the .iso with wubi but it didn't work so I though they had removed that option, thanks so much. – Alex B May 14 '13 at 21:50
Great! Glad it worked out. Wubi is great to try out Ubuntu, but I would advise keeping up to date data backups for anything stored on the virtual disk. – bcbc May 14 '13 at 22:17

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.