Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

First off, I just want to say that I work as an IT engineer (Windows Desktop/Server etc) so I am willing to go right down to the ground when it comes to advance technical troubleshooting. Unfortunately however I am new to Linux so please be gentle at the same time.


The issue:

Ever since upgrading my HP Pavilion G6 laptop from Ubuntu 12.10 to 13.04 my wireless is not functioning correctly. The main issue is that if I sit upstairs the wireless signal drops to around '2' bars and the download speeds (according to speedtest.net) are extremely slow (0.26Mbps). However if I go and sit down stairs right in front of my router I get full signal and speedtest.net shows a fast connection (around 40Mbps).

This does not happen on Ubuntu 12.10. Sat both upstairs and downstairs I can get a strong signal and speed test results of up to 40Mbps.

I can provide screenshots of results if evidence is required.

Naturally, this issue is causing my second problem. Periodically at random times the connection to the Wifi will request for the Wifi password (clearly the password is correct as all other devices connect fine and it was just working on this password). If I try clicking OK to accept the password entered it will retry to connect for a few moments before requesting the password once again. This will end up in a continuous loop until I restart the laptop.


What I have tried/researched:

So from numerous google searches, askubuntu questions, guides for troubleshooting wifi, knowledge bases for hardware type etc. etc. It would seem that the issue is relating to the updated version of the wireless driver built in to the open source drivers when Ubuntu is deployed.

To the point:

Running the following commands on both 12.10 and 13.04 shows the following results:

Ubuntu 12.10

root@chris-test:~# lshw -C network

*-network               
   description: Wireless interface
   product: Ralink corp.
   vendor: Ralink corp.
   physical id: 0
   bus info: pci@0000:01:00.0
   logical name: wlan0
   version: 00
   serial: 68:94:23:0d:0e:db
   width: 32 bits
   clock: 33MHz
   capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
   configuration: broadcast=yes driver=rt2800pci driverversion=3.5.0-22-generic firmware=0.34 ip=192.168.15.225 latency=0 link=yes multicast=yes wireless=IEEE 802.11bgn
   resources: irq:16 memory:52500000-5250ffff
*-network
   description: Ethernet interface
   product: RTL8101E/RTL8102E PCI Express Fast Ethernet controller
   vendor: Realtek Semiconductor Co., Ltd.
   physical id: 0
   bus info: pci@0000:02:00.0
   logical name: eth0
   version: 05
   serial: 28:92:4a:56:90:7e
   size: 10Mbit/s
   capacity: 100Mbit/s
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
   configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=half firmware=rtl_nic/rtl8105e-1.fw latency=0 link=no multicast=yes port=MII speed=10Mbit/s
   resources: irq:42 ioport:3000(size=256) memory:52404000-52404fff memory:52400000-52403fff

root@chris-test:~# lspci -nnk | grep -iA2 net
01:00.0 Network controller [0280]: Ralink corp. Device [1814:539b]
Subsystem: Hewlett-Packard Company Device [103c:18ed]
Kernel driver in use: rt2800pci
--
02:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller [10ec:8136] (rev 05)
Subsystem: Hewlett-Packard Company Device [103c:183f]
Kernel driver in use: r8169

Ubuntu 13.04

root@chris-laptop:~# lshw -C network
*-network               
   description: Wireless interface
   product: Ralink corp.
   vendor: Ralink corp.
   physical id: 0
   bus info: pci@0000:01:00.0
   logical name: wlan0
   version: 00
   serial: 68:94:23:0d:0e:db
   width: 32 bits
   clock: 33MHz
   capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
   configuration: broadcast=yes driver=rt2800pci driverversion=3.8.0-19-generic firmware=0.34 ip=192.168.15.225 latency=0 link=yes multicast=yes wireless=IEEE 802.11bgn
   resources: irq:16 memory:52500000-5250ffff
*-network
   description: Ethernet interface
   product: RTL8101E/RTL8102E PCI Express Fast Ethernet controller
   vendor: Realtek Semiconductor Co., Ltd.
   physical id: 0
   bus info: pci@0000:02:00.0
   logical name: eth0
   version: 05
   serial: 28:92:4a:56:90:7e
   size: 10Mbit/s
   capacity: 100Mbit/s
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
   configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=half firmware=rtl_nic/rtl8105e-1.fw latency=0 link=no multicast=yes port=MII speed=10Mbit/s
   resources: irq:43 ioport:3000(size=256) memory:52404000-52404fff memory:52400000-52403fff

root@chris-laptop:~# lspci -nnk | grep -iA2 net
01:00.0 Network controller [0280]: Ralink corp. Device [1814:539b]
Subsystem: Hewlett-Packard Company Device [103c:18ed]
Kernel driver in use: rt2800pci
02:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller [10ec:8136] (rev 05)
Subsystem: Hewlett-Packard Company Device [103c:183f]
Kernel driver in use: r8169

So from what I can see, the only main difference here is the 'driverversion' on both distros.

Ubuntu 12.10:

configuration: broadcast=yes driver=rt2800pci driverversion=3.5.0-22-generic firmware=0.34 ip=192.168.15.225 latency=0 link=yes multicast=yes wireless=IEEE 802.11bgn

driverversion=3.5.0.22-generic

Ubuntu 13.04:

configuration: broadcast=yes driver=rt2800pci driverversion=3.8.0-19-generic firmware=0.34 ip=192.168.15.225 latency=0 link=yes multicast=yes wireless=IEEE 802.11bgn

drivervesrion=3.8.0.19-generic

I can only imagine that something has been changed in the newer versions which is actually causing problems with my wireless card.


So what I think I may need to do is push this driver to the older version? Can anyone confirm this as a possible fix? Is anyone able to tell me that I am barking up the completely wrong tree?

I hope this has been informative enough for someone to provide some help. If any further information is required, as mentioned earlier, I am more than happy to run further commands and tests to try and isolate the issue.

P.S. Thanks in advance for your time and consideration.


Update

So I had a very interesting moment last night!

My DVD drive was unable to open the tray when pressing the button and would no longer read DVDs.

I connected the mains power to my laptop and hey presto, my DVD drive started working again.

Leaving the mains connected I tried running a speedtest on the wifi. (40Mbps - roughly full capability of my line).

However, I have tried the battery on 12.10 and there is no problem what so ever.

My assumption

From discovering this, I can only assume that 13.04 is not supporting my battery/power settings correctly?

The other possibility is that battery itself is faulty, but when I run a battery test from the HP UEFI it does not appear to show any errors.

Thoughts?

Update 19/09/13

So following on from this, I have tried updating the 13.04 partition kernel to 3.9 rather than 3.8 which has solved the problem for some people according to a number of bug trackers.

Unfortunately, this has not solved the problem for me. This makes me think it is more than likely a kernel issue with these drivers.

Any further thoughts?

share|improve this question
    
Another thing: If you compare the driver name to the name of your WiFi card, you'll see that they are different. Download the correct driver from Realtek's website, this sped up my eth0 about 10 times, maybe it has effects on your WiFi –  the_Seppi Oct 2 '13 at 19:52

4 Answers 4

I suggest your try two things:

echo "options rt2800pci nohwcrypt=1" | sudo tee /etc/modprobe.d/rt2800pci.conf

sudo modprobe -rfv rt2800pci

sudo modprobe -v rt2800pci

I believe power management is the main issue, please do:

gksudo gedit /etc/pm/power.d/wireless

(this will create or edit a configuration file that will override the default power management behavior) and enter the following:

#!/bin/sh

/sbin/iwconfig wlan0 power off

above exit0, then save gedit, close and reboot.

Thanks

share|improve this answer
1  
Apologies for not coming back on this. Been investigating via MANY other channels. It appears to have been reported in a number of bug reports regarding this open-driver. Unfortunately I have still been unsuccessful with resolving this. The only difference I can see is the kernel version which could be causing the problem. I have tried upgrading to the 3.9 but I am still experiencing the problem. Any other thoughts? –  CTilley147 Sep 19 '13 at 13:31

Unfortunately not a solution from me. Those driver versions are in fact the kernel versions. The driver modules are delivered as part of the kernel itself, so downgrading won't be easy.

ls /lib/modules/`uname -r`/kernel/drivers/net/wireless/

For me I gave up on the ralink based wifi card a while ago because of similar problems on various linux distros, however it may be worth trying the solution proposed here by Hadaka of disabling hwcrypt for the driver (albeit for 12.04):

share|improve this answer
    
I saw something similar to this the other night but I think I brushed over it because it was for 12.04. I'll give it a shot and post my findings. –  CTilley147 May 14 '13 at 12:58
1  
Unfortunately this does not appear to have changed anything. Still get very weak signal where in 12.10 it is strong signal. Also the connection is dropping randomly. –  CTilley147 May 14 '13 at 17:47

So through extensive research and patience I have managed to resolve this issue on my HP Pavilion G6 using the RT5390sta driver. I am now getting the full 40Mbps downstream (just under) and around 10Mbps upstream (never been much higher anyhow) of our fibre line.

What I did to solve the problem

Firstly I saw a lot of people suggesting that upgrading their kernel to 3.9 would work, but unfortunately this did not work for me.

After spending so much time trying to solve this, kernel 3.11.1 (stable) has been released and I installed this as instructed by the below link:

http://ubuntuhandbook.org/index.php/2013/09/kernel-3-11-1-released-install-upgrade-in-ubuntu-linux-mint/

use wget to retrieve .deb files

wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.11.1-saucy/linux-headers-3.11.1-031101-generic_3.11.1-031101.201309141102_amd64.deb

wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.11.1-saucy/linux-headers-3.11.1-031101_3.11.1-031101.201309141102_all.deb

wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.11.1-saucy/linux-image-3.11.1-031101-generic_3.11.1-031101.201309141102_amd64.deb

then install these .deb files using dpkg -i

sudo dpkg -i linux-headers-3.11.1*.deb linux-image-3.11.1*.deb

Updated grub (if needed):

update-grub

Checked kernel after reboot:

uname -a

After installing this kernel I followed a post (#14) on the below bug tracking site:

https://bugs.launchpad.net/ubuntu/+bug/1173759

  1. download driver http://www.mediatek.com/_en/07_downloads/01-1_windowsDetail.php?sn=5001
  2. tar -xvf /home/ukbeast/USERNAME/Downloads/2011_1007_RT5390_RT5392_Linux_STA_V2.5.0.3_DPO_v2. bz2.bz2
  3. cd 2011_1007_RT5390_RT5392_Linux_STA_V2.5.0.3_DPO
  4. download patch http://gridlox.net/diff/rt5592sta_fix_64bit_3.8.patch to the directory above
  5. patch -p1 <rt5592sta_fix_64bit_3.8.patch (if asks for directory point it to pci_main_dev.c)
  6. make sure /os/linux/config.mk reads HAS_NATIVE_WPA_SUPPLICANT_SUPPORT=y
  7. make
  8. sudo make install
  9. modprobe rt5390sta

After all this my speed tests shot back up to the expected rates. It may have bee nthe driver and patch, or alternatively could just have been kernel 3.11.1 but either way, these steps managed to resolve my issue.

share|improve this answer
    
have you tried installing the driver before trying a custom kernel? –  BЈовић Oct 15 '13 at 22:05
    
I had the same problem with my Laptop and it was solved by updating the kernel. –  Jirico Feb 16 at 5:38

I think this will help you. I like to use WICD because it is a simple and easy to use network manager. Its a very good alternative to network manager in Ubuntu and it seems to always work when Network Manager doesn't. To install it just open up the terminal. Now download the latest NetworkManager, in case you need to reinstall it if WICD doesn't work sudo apt-get install -d --reinstall network-manager network-manager-gnome

Then to install it sudo apt-get install wicd-gtk

And now you need to uninstall NetworkManager: sudo apt-get remove --purge network-manager-gnome network-manager

Now you can find WICD in your menu Start WICD, find the network you want to use and enter the information needed, password, encryption, etcetera and choose Automatically Connect to this network. You should be good to go!

WICD may also be available in Ubuntu Update Manager so you can look there first but it is important to uninstall Network Manager completely to prevent conflicts!!

share|improve this answer

protected by Community May 27 '13 at 18:13

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.