Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

On my Xubuntu 13.04 installation, when the sound is turned up to high levels (>50%), it begins to (randomly?) fluctuate between loud and quiet. In pavucontrol, the port setting is fluctuating between "Analogue output" and "Headphones" (I'm using desktop speakers plugged into the integrated audio line out).

Any ideas?

share|improve this question
    
I uninstalled pulseaudio, which seems to have fixed it. Edit: oh wait, sorry, no! It's still broken :( –  Fela Maslen May 13 '13 at 19:49

2 Answers 2

The most probably your plug is plugged bad. Double check it, check if it happen when you move/turn/touch your PC.

share|improve this answer
    
No, it happens when I turn the volume above 50% (without fail). The speakers are plugged in fine. –  Fela Maslen May 13 '13 at 19:51
    
There is a known bug but I can't find it atm, I've been experiencing this for the last ~6 months or so. It occurs more often when you turn the volume up louder, and it will jump back and forth between internal/output. In my case this is on a laptop that never had this problem before I did updates one day. Problem was I didn't realize it was happening for about a week, and I never bothered to check what updates had been done. About 2 months later I noticed a bug pop up on, iirc, bugzilla.novell.com –  l300lvl May 13 '13 at 20:52
    
Thanks, so it wasn't just me. Anyway, I've "fixed" it by first uninstalling pulseaudio, then disabling the auto-mute using alsamixer. –  Fela Maslen May 13 '13 at 20:53

Same problem in MATE and Ubuntu 12.04. It seems to be random changes by the widget. This is more a workaround.

I've tested this forum's solution.

  1. Open daemon.conf with your favorite editor (mine is gedit)

    sudo gedit /etc/pulse/daemon.conf
    
  2. Find

    ;flat-volumes = yes

  3. Under it, type in the following (do not use a semi-colon) :

    flat-volumes = no
    
  4. Save the file.

  5. In the terminal type in the following commands as your current user (not as root) :

    pulseaudio -k
    pulseaudio --start
    
  6. Also you need to install and use pavucoontrol

    sudo apt-get install pavucontrol
    
  7. After installation open pavucontrol

    pavucontrol
    
  8. Change your settings to the image at the next link, including the lock and desired volume. Note: headphones="Auriculares analogicos". There are several outputs, level the volume to check which are working. Configuration from your headphones="Auriculares analogicos" (Sorry, i don't have enough reputation to post the image directly. I'll change it ASAP when i can)

  9. This is not a solution because you'll need to leave pavucontrol open. I don't want make a test leaving pavucontrol closed. I just put the console and the pavucontrol window in another desktop and leave it open.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.