Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed Ubuntu Linux on my Thinkpad T430 and everything works until last week. Because then I bought a new monitor with a higher screen resolution than full hd. So I cannot run the monitor with a higher resolution than 1920*1080.

The T430 is running with two graphic cards:

  • Intel HD 4000
  • Nvidia Quadro NVS 5400M

The notebook also allows running in "Optimus" mode.

I want to use the Thinkpad T430 and two monitors:

  • one with FULL HD resolution on the VGA port
  • and one with 2550x1400 resolution on the mini Display port

I tried these approaches:

Optimus mode = enabled In BIOS I enabled the Optimus mode (without bumblebee) and in Ubuntu 13.04 everything works, even both monitors get detected. But the problem is, the monitor connected to the mini display port (2550x1400) doesn't render the mouse courser correctly. It is laggy, so ALL mouse positions of the courser of the last 5 seconds are shown.

In this setup no extra software is installed, only the drivers delivered by ubuntu. This works so far the best. Only the mouse courser problem sucks. But I don't know what to do about that. Any suggestions?

Optimus mode = disabled, run only on Nvidia graphic card I installed Ubuntu 13.04 with only the Nvidia graphic card enabled. Works fine. But I can only run one monitor (which would be okay), but the max resolution was 1920*1080, even on the monitor with a higher default resolution.

Any suggestions to fix that?

Optimus mode=disabled/enabled, use Nvidia drivers I also tried installing the nvidia drivers via 'sudo apt-get install nvidia-current' but that did not work. After that the system does not boot anymore. Only a black screen is shown after boot loader. The system only boots if I enable optimus mode. I assume that the Intel graphic card is used in that case.

*bumblebee I tried installing bumblebee with optimus mode=enabled. I got it installed, but it did not get the monitor on the mini display port detected. So it didn't work as I assumed it would.

I am not a linux expert and I am really stuck with this problem. Do you guys have any ideas or suggestions how I can get either the nvidia graphic card or the optimus mode running? I don't care if the battery is running out of energy very fast.

If you need anything else, please let me know. Thanks for your help.

Kind regards

Q

share|improve this question
    
This issue affects me as well. –  Jeff Phelan Sep 19 at 7:56

1 Answer 1

I have same problems with my Alienware M17xR4 (intel 4000 and nvidia 675M).

After googling for a while i found that your laptop has only VGA and Mini DisplayPort. Unfortunately same trick does not work over DpisplayPort (I still get those lags on mouse and while scrolling or watching movies) so this probably will not work for You but it might help someone else.

So far the best solution i found is to run one monitor through VGA

and the second one (2560x1440) through HDMI cable with lowered refresh rate suggested by Linus Torvalds in his g+ post https://plus.google.com/+LinusTorvalds/posts/HQsCY7ErAL4

With this workaround everything seems to work fluent even movies.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.