Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I was playing around with compizconfig. I don't remember what exactly I clicked. Since then, the close/minimize buttons and the sidebar vanished. I use 12.10 version. Please help me out.

share|improve this question

3 Answers 3

Please be aware of the issues you may be faced when running ccsm:

You most likely disabled the windows decoration in the "Effects" section like I did in the example below:

enter image description here

To re-enable them just tick this box and wait until Compiz restored the windows decorations.

In case we had opened the further settings of the Windows Decoration plugin we may need to restore them to defaults shown below:

enter image description here

To remove bad settings we may have made with ccsm we may also try to delete its configuration files in ~/.config/compiz-1 with

mv ~/.config/compiz-1 ~/.config/compiz-1.old
share|improve this answer
    
Yes. I remember disabling the decoration effect. But, how do I get the Compizconfig window as in the screenshot? Only the terminal works in the empty homescreen. –  user158374 May 14 '13 at 14:44
    
I've ticked the option. No effect even after restarting –  user158374 May 14 '13 at 15:05

Check if you have CompizConfig Settings Manager > Window Decoration enabled and check if CompizConfig Settings Manager > Window Decoration > Command has the default value /usr/bin/compiz-decorator.

share|improve this answer
    
The homescreen is totally empty. Please suggest me a way to get into CompizConfig Settings Manager. –  user158374 May 14 '13 at 14:45
    
@user158374 Open a terminal (Ctrl+Alt+T) and type in ccsm. It will open CompizConfig Settings Manager. –  Radu Rădeanu May 14 '13 at 14:47
    
@user158374 And accept the answer if you solved the problem. –  Radu Rădeanu May 14 '13 at 14:49
    
Sorry, the command has the default value as specified. But in vain. Not getting the buttons. –  user158374 May 14 '13 at 15:00

Try (in terminal)

gsettings set org.gnome.desktop.wm.preferences button-layout ':minimize,maximize,close,' 

moving the : to the end (like this gsettings set org.gnome.desktop.wm.preferences button-layout 'minimize,maximize,close:') and then restarting to see if they reappear for you.

Let us know.

Cheers!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.