Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have the impression that Japanese input method editor (変換) is not as good as it used to be (can't tell since when).

When I type "terekomu" and transform, the IME does not propose テレコム (a very usual word) but テレ込む which makes no sense.

Using Ubuntu 10.10, everything by default (which means iBus 1.3.7/Anthy).

Is it a known bug I just did not notice before? Can I fix it somehow?

share|improve this question

2 Answers 2

up vote 2 down vote accepted

It works with Google Japan's ibus-mozc:

Two ways to install it:

1) Search the Ubuntu Software Center for "ibus-mozc"

OR

2) Install it in the terminal below:

sudo add-apt-repository ppa:japaneseteam/ppa
sudo apt-get update
sudo apt-get install ibus-mozc

You might need to restart the GUI or log out. You should then be able to select "ibus-mozc" in the keyboard dropdown in the top right panel under preferences.

(For anyone else, this assumes you've already installed Japanese)

share|improve this answer
    
I installed by command line and restarted, I added Mozc as an input method in the IBus Preferences, but still the same テレ込む... actually it looks no different from before. How can I make sure I am using mozc? When I left-click on the IBus status icon I can see that "Mozc - Japanese" is selected". –  Nicolas Raoul May 9 '11 at 0:09
    
Yeah, and the keyboard icon should change to show an orange icon when it's activated. Make sure Anthy is not selected if both are in the list.. If that doesn't work then I don't know what will. This is what I see: link –  Frychiko May 15 '11 at 15:12
    
I removed Anthy altogether from the preferences list, but I think it is still being called, even though Mozc is always the one selected in the status bar icon's contextual menu. I will try to uninstall Anthy from the whole system. –  Nicolas Raoul May 16 '11 at 1:08
    
Thanks! mozc has its own problematic words but it spells テレコム correctly :-) –  Nicolas Raoul May 29 '11 at 14:37
    
I had always been bothered by the suggested choices when entering Japanese, but I never thought that it was something that could be changed. This solution works for me on Ubuntu 12.04, Gnome-classic, and it should be noted that I also had to completely uninstall Anthy to start seeing an improvement. –  Dave M G Jul 30 '12 at 6:36

tested and I think it is a bug It splits 'terekomu' into two words, 'tere' and 'komu' with underscore using spacebar to change to rewrite mode, <- and -> to select word and then spacebar to rewrite word. テレコム :)

share|improve this answer
    
Note that you need to hold down the shift key when using the arrow keys in order to change the portion of the word being changed. In any case, though, this is not entirely a satisfactory solution because if one is not a native speaker, it's helpful to have more accurate suggestions and not have to force the IME. Also, even you are a native speaker, additional unneccessary keystrokes are never desired. –  Dave M G Jul 30 '12 at 6:39

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.