Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have server running Ubuntu 10.10. Never used samba before, as I never had windows machines, but now I need it.

So I did: apt-get install samba smbfs smbclient.

Packages are installed, but I have no idea how to configure it. All howtos I found on the net relate to /etc/samba/something.conf, where I don't even have /etc/samba directory.

The only config I found is /etc/default/samba, which contains (aside from comments) only:

RUN_MODE="daemons"

All I want is to be able to have access to some directories on the Ubuntu machine from Windows, nothing else.

share|improve this question
    
If you have the IP of the windows machine, just type this in an explorer: smb://x.x.x.x –  theTuxRacer Mar 8 '11 at 8:48
    
@depesz are you using(installing samba) on ubuntu server or ubuntu Desktop? –  Achu Mar 8 '11 at 9:19
    
@Kaustubh P - not sure I understand. I have both windows and linux ips, but I need to connect from windows to linux samba, so I can see (from windows) some directories on Linux server. –  user12008 Mar 8 '11 at 10:41
    
@Achu: server. As 3rd word in description suggests :) –  user12008 Mar 8 '11 at 10:41
1  
First remove system-config-samba as it is a gui then reinstall samba and samba common "apt-get install xyz --reinstall" –  Allan Mar 8 '11 at 16:15
show 4 more comments

4 Answers 4

up vote 0 down vote accepted

Installing the "samba" package should have also installed the "samba-common" package which contains the /etc/samba/smb.conf file.

A lot of things depend on samba-common (including, indirectly, GNOME) so you probably had it installed before you installed Samba. Perhaps this directory was deleted by accident at some point?

You should be able to create it again from scratch by reinstalling the samba-common package, or by simply creating it manually. The only file that really matters in that directory is smb.conf.

share|improve this answer
add comment

I'm not too sure about setting Samba up on a server but the steps listed here worked for me to allow two Ubuntu pc's to share files with Windows pc's on my network.

share|improve this answer
    
This doc also refers to /etc/samba directory/files which I do not have. –  user12008 Mar 8 '11 at 16:05
add comment

This question has been dealt with at length in the ubuntu documentation.

  • https://help.ubuntu.com/8.04/internet/C/networking-shares.html

    • This link provides instructions on how to share folder graphically. i.e with a gnome gui. Using a right click as described above. It also details potential missing dependencies in order to enable right click sharing.
  • Assuming you are using gnome with a default installation.

  • Simply locate a folder in Nautilus or the file browser and

    • right click on the folder,
    • select properties
    • select the share tab
    • tick the share this folder box
    • Assign privileges necessary
    • tick allow guest access to enable people to browse the share on the network.
    • tick allow other to create and delete to allow users on the network to delete and create directories.
  • https://help.ubuntu.com/community/Samba/SambaClientGuide

    • This link contains a detailed discussion on command line use of samba, samba configuration with from /etc/samba/smb.conf.
    • Recommend this for advanced configuration and advanced users, or those having trouble sharing between windows.
share|improve this answer
    
This answer has nothing to do with question. I already stated that there is no graphical environment, and the problem is not that I can't configure it, but that configuration file was altogether missing. –  user12008 Mar 16 '11 at 6:26
add comment

Or you could simply use Webmin which is a web-based admin tool.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.