Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I done my below option in my netbook Acer Aspire One D260 netbook version.

  1. I tried to upgrade my Ubuntu version from 11.10 to 12.04. Unfortunately it was stopped due to my internet disconnect.
  2. I tired to kill all the process using system monitor tool (select all process and press end process).

After above all those action my system not responding whenever I tried to shut down or log out.
I tried in terminal window using shutdown -h now command, but it tells that need to be root. But hibernate and suspend options are working fine.

Can anyone guide me how to solve this issue? Thanks in advance!

share|improve this question
    
Use sudo shutdown -h now instead of shutdown -h now to execute the command as root. –  Radu Rădeanu May 13 '13 at 12:25
add comment

2 Answers 2

To fix it, you must to edit grub file as follow: Type in terminal:

  1. Type in terminal: sudo -H gedit /etc/default/grub
  2. Find the line: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
  3. Change this to: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi=force"
  4. Save and close the file.
  5. Finally, in terminal: sudo update-grub and sudo reboot.
share|improve this answer
    
Dear friends, tried above steps but i got reply as" command not found". is any other possibility of solution there? –  Ramanathan May 15 '13 at 2:28
    
@Ramanathan94 Which command? –  Radu Rădeanu May 15 '13 at 5:20
    
i tried with this commends in terminal window"sudo gedit /etc/default/grub". i got an answer as " command not found" –  Ramanathan May 15 '13 at 16:28
add comment

You have to use sudo to execute the command as root:

sudo shutdown -h now
share|improve this answer
    
I tried "sudo shutdown -h now" comments. i am getting no comments found answer in terminal window –  Ramanathan May 15 '13 at 2:31
    
Hi All,now my netbook responding the comments "sudo shutdown -h now".i can able to shutdown my system.But how long should I use this comments. every time use this comments is not fair for Ubuntu. is any permanent solution there to rectify this issue? –  Ramanathan May 28 '13 at 1:09
    
What do you mean by "it is not fair for Ubuntu?". This is the proper way to shut down an Ubuntu system via command line. –  André Stannek May 28 '13 at 7:16
    
i mean to say is, usually i shunting down using "shutdown" command from power menu. now every time i am using terminal window. I feel its tedious. do u knew how to rectify this issue –  Ramanathan May 29 '13 at 13:59
    
So the shutdown option is not working at all anymore, even after reboot? If so you should ask a new question instead of discussing this in the comments. –  André Stannek May 29 '13 at 14:07
show 1 more comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.