Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've been trying to install Ubuntu 10.10 as a dual boot with Windows 7 on my Dell latitude e6510. It is currently running Windows 7 and I have used the MS disk tools to shrink the Win 7 NTFS partition to make room for Linux.

The issue I'm having is that when I run Ubuntus installer by booting from CD it sees the entire hard drive as unallocated space.

I have also tried Kbuntu 10.10, Fedora 14, booting a Gparted 0.8.0 usb drive, and Ubuntu "install in Windows" with wubi they all have problems.


When I run the "try Ubuntu" option on booting from cd it can mount my Windows partition and I can view the files.

The output of sudo parted -l when running in try Ubuntu mode:

Warning: /dev/sda contains GPT signatures, indicating that it has a GPT table.
However, it does not have a valid fake msdos partition table, as it should.
Perhaps it was corrupted -- possibly by a program that doesn't understand GPT
partition tables.  Or perhaps you deleted the GPT table, and are now using an
msdos partition table.  Is this a GPT partition table?

Yes/No? yes
Model: ATA ST9500420AS (scsi)
Disk /dev/sda: 500GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt

Number  Start  End  Size  File system  Name  Flags

Warning: Unable to open /dev/sr0 read-write (Read-only file system).  /dev/sr0
has been opened read-only.

Error: /dev/sr0: unrecognised disk label
share|improve this question
Can you post the output of sudo parted -l ? – belacqua Mar 8 '11 at 5:11
added output above – Nash0 Mar 8 '11 at 6:02
It is probably not a good idea to use a GPT partition table on a BIOS (not EFI) based computer. Unlike Ubuntu GPT support from Windows is incomplete on BIOS based computers. – Takkat Mar 8 '11 at 7:32
You should have left the hard drive as is - Ubuntu is much better at resizing partitions. – sevenseacat Mar 8 '11 at 11:47

It turns out my laptop somehow was given two partition tables an MBR and a GPT, which some Linux tools. Clearing (Erasing) the GPT using Gdisk for windows fixed the situation. Both Windows and Ubuntu can read my drive now.

GPT fdisk at sourceforge

GPT fdisk Tutorial

share|improve this answer

I found the following info looking on the Ubuntu Certified Hardware page - due to the hardware of this Dell laptop you need to contact Dell for a version of Ubuntu suitable, see

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.