Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This is Manorath. I tried all the options explained in the help page regarding uefi mode when I boot my sony vaio which already contain windows 8 in uefi mode when I am using the ubuntu cd as my first boot it is not detecting the os in the cd it is giving error like "no os found" .

So I request you to give any solution on this problem. And also I am unable to install ubuntu inside windows 8. if it is getting installed then at the time of booting when I select the ubuntu then it is giving some memory error.

Plz help on this topic.

share|improve this question
    
Disable UEFI in BIOS. –  smile May 13 '13 at 12:12
    
Did you already check askubuntu.com/questions/221835/… ? –  Eric Carvalho May 13 '13 at 12:37
    
Disabling UEFI in the firmware will likely result in a BIOS/CSM/legacy-mode install of Linux and an EFI-mode install of Windows. It can be awkward to switch boot modes on a boot-by-boot basis, so I don't think that's a good solution unless you're willing to install an EFI boot loader for Linux after the fact. This is possible, but it's usually easier to get the install working in EFI mode to begin with. –  Rod Smith May 13 '13 at 14:35

2 Answers 2

You may have a similar VAIO to what I have. If you have a partial SSD, then your hard drive is setup as a FakeRAID 0 and Ubuntu doesn't support it. You'll have to fully wipe your hard drive and start over with whichever OS(s) you want. You still have to disable Secure Boot and enable Legacy Boot, but once you have a hard drive in there that Ubuntu can read, you'll be fine. Sony has a weird BIOS setup that won't even read the Win8 OS when you enable Legacy Boot. My wife won't let me wipe this PC, so I just run Ubuntu as a Virtual Machine using VMware Player.... Worked for months trying to get around this.... Hope this helps.

share|improve this answer
    
Thanks theB3 for ur valuable comment. –  Manorath Mishra May 14 '13 at 4:35

First, I recommend you enter your firmware setup utility (usually done by pressing Del or a function key just after powering on the computer) and disabling Secure Boot. Unfortunately, the details of how to do this vary from one computer to another, so I can't be very precise about how to do it.

If that doesn't work, then you might try downloading the USB flash drive version of my rEFInd boot manager and booting from that while the Ubuntu CD is in the drive. With any luck, rEFInd will detect the Ubuntu CD and give you a boot option for it, and that will work. If you don't see the Ubuntu CD immediately, try hitting the Esc key.

If that doesn't work, try creating a bootable USB flash drive from the Ubuntu CD. It's possible that your computer will like that better than a CD.

One more point: The option to install Ubuntu within Windows (that is, using WUBI) is unsupported on EFI-based computers, which yours is. Don't try to get that working, since it's a waste of time.

share|improve this answer
    
It is not working by doing this. can you share a video link explaining this. –  Manorath Mishra May 14 '13 at 4:37

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.