Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Since yesterday I'm unable to start QtCreator. Trying to start QtCreator from terminal gives me this error message, which I haven't found anything on:

qtcreator: symbol lookup error: /usr/lib/x86_64-linux-gnu/qt5/plugins/platforms/libqxcb.so: undefined symbol: _ZN15QPlatformWindow17formatWindowTitleERK7QStringS2_

Any ideas what this is about?

Running Ubuntu 13.04 with qt5-edgers ppa for both Ubuntu SDK and Qt.

Version of QtCreator: 2.7.0-0ubuntu4~raring1~test5

share|improve this question
    
Did you change the LD_LIBRARY_PATH variable in your .bashrc file? –  hakermania May 13 '13 at 12:08
    
I've not done that recently, no. What should it be set to? –  Daniel Holm May 13 '13 at 12:46
    
Searching a bit in google revealed that you may have installed 2 versions of Qt in a single system. I am not sure, though. –  hakermania May 13 '13 at 12:49
    
Like Qt4 and Qt5? –  Daniel Holm May 13 '13 at 13:06
    
Thanks hakermania, I removed all Qt4 stuff and it works now. –  Daniel Holm May 13 '13 at 13:13

2 Answers 2

The problem happens rarely but is related to upgrading from for example the archive version of ubuntu-sdk, or maybe some more complex upgrade path. The root problem is currently unknown, but removing and reinstalling Qt 5 seems to work.

  1. Remove libqt5core5 package, to remove most of the Qt 5
  2. Install ubuntu-sdk package to get the Qt 5 and the rest of the Ubuntu SDK back.
share|improve this answer
    
Thanks, this is clearer and solves the problem ^_^ –  Inoe Jun 16 '13 at 11:10
up vote 2 down vote accepted

Somehow it seemed like I had two Qt versions installed (thanks hakermania). After I've removed all Qt4 stuff and reinstalled Ubuntu SDK and QtCreator (again) it worked.

share|improve this answer
    
You are welcome, make sure to accept your answer when you can. –  hakermania May 13 '13 at 13:14
    
Will do. Thanks again. –  Daniel Holm May 13 '13 at 13:59

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.