Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When I do a fresh install of Ubuntu 13.04 on a computer with an older Nvidia Quadro FX 500 128mb agp card, I cannot get the display to work.

There are a number of things that happen: On some fresh installs the screen goes completely yellow. After other fresh installs the screen goes completely black.

I have tried to install the Nvidia drivers titled: current, current-updates, and nouveau. When I install one of these drivers, the desktop becomes visible with a 640x480 resolution and no unity. I can right-click on the background and navigate up to the settings, where I see the display settings only recognize the monitor as "laptop" and stay stuck in that one resolution option.

The farthest I have gotten is using this answer which allowed me to see the entire desktop at the proper resolution, but no unity launcher or top panel. Upon restart the resolution reverts back to 1280x1024, which does not conform to the monitor (leaves about 3 inches of blank space on either side of the image) and unity is still not present.

??????????? Which is the proper driver for an older Nvidia card? How do I restart Unity so that appears again? What is the display setup process once I have done a fresh install (since it is not auto-detecting)?

Many thanks

share|improve this question
up vote 0 down vote accepted

Same prob here with Quadro FX card. My fix in 12.10 was to remove any trace of Unity and use an alternate environment.

Unity was my issue, and avoiding it solves the problem. Ubuntu Studio 13.04 (for multimedia production) runs Xfce instead of Unity and works perfectly after installing nvidia-current.

share|improve this answer

salam :) nouveau nvidia driver are not working for some nVidia Cards (Use Recovery Mode if you have Black screen) First install Linux headers and source:

 sudo apt-get install linux-source linux-headers

Remove the nVidida Drivers if they are installed

 sudo apt-get remove nvidia-current nvidia-current-updates

Install them from this repo:

sudo apt-add-repository ppa:xorg-edgers/ppa; sudo apt-get update ; sudo apt-get install nvidia-current nvidia-settings

If that is not working, use the Drivers from the 'Additional Drivers' Panel.

share|improve this answer
Thanks for the quick response. However, this method did not fix my problem. I tried this on a fresh install, and it resulted in an acceptable monitor resolution of 1280x1024, but with black on 3 inches of each side of the screen and no Unity launcher or panel. In Display Settings it only detects the screen as "laptop", and has 3 resolution options. In the settings I also mysteriously cannot click on the Additional Software Sources tab. Is it possible that 13.04 simply does not work on this old of a computer? It is a 64 bit. The last working edition is 10.04. – Rockishi May 19 '13 at 0:52

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.