Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

To begin with, for some reason I had a problem with wine - every program I launched crashed with a strange error and pretty much nothing would execute except for applications and executables stored on my Xubuntu partition. I thought that updating wine would fix the problem but after upgrading to 1.5 I see no difference - the same error occurs over and over again:

http://pastebin.com/rRXsP6EA

I think I've always had similar problems with wine. However, I decided to do some research and a person from another forum claimed that his inability to execute files from partitions with wine was due to a 'users' option in /etc/fstab. I currently have 1 ntfs partition for Windows, 1 ext4 for Xubuntu, 1 ext2 and 6 ntfs for file storage and 1 swap partition. All my file storage partitions were configured with a 'users' option and I removed it. On the positive side, all my executable files would actually execute without an error from every partition I tried. On the negative side, however, I'm not able to see any of my partitions in the Places Menu. They are mounted from /dev/sdaX to /media/sdaX but my Places menu doesn't show them. It shows only my Xubuntu and Windows partitions.

So far I've tried altering the fstab options for my ext2 and ntfs partitions a bit by adding a uid and umask and putting ntfs-3g instead of only ntfs but it's either no exes and visible drives or invisible drives and working exes (depending on whether the 'user' or 'users' option is added).

If there's any substitute to the xfce4-places-plugin which would certainly work with xfce4 and show my drives, gtk bookmarks and home folder, I'd be more than happy to use it.

Any help is appreciated. Thank you in advance!

EDIT: Just downgraded to 1.4.1 because some games and applications seemed blurry and this fixed it but the error still occurs.

share|improve this question
    
"Unhandled exception: page fault on read access" looks like a Wine internal bug, it does not look like anything related to mounting. As a matter of fact, only Wine's internal libraries are in the backtrace (kernel32/ntdll/libwine.so), and the executable is not even among the loaded modules. Additionally, as long as you are able to read the file (partition is mounted & you have permission), Wine can read it for sure. Does using a 32-bit Wine prefix solve the issue? (I've read it in a forum, but don't know if that's related, just suggesting) –  ignis May 13 '13 at 10:56
    
Well, I tried creating a 32 bit prefix but it made no difference... If it's due to wine how come would I be able to launch exes from my Xubuntu partition and not from any other partitions? When I remove the 'users' option from fstab I'm able to launch my executable files with wine but I can't see my drives in the Places Menu. –  Abvgz May 13 '13 at 11:55

1 Answer 1

Well, I managed to fix this myself. It turned out that the 'users' option brought 'noexec' with itself and it was necessary to manually add the 'exec' option to the fstab partition entries.

This is an example of a line from /etc/fstab containing mounting a ntfs partition in order to allow executing:

/dev/sdaX /media/sdaX ntfs-3g uid=username,umask=077,users,exec 0 0

Where X is the number of the partition and username is your username.

The 'exec' option MUST be at the end, otherwise it won't work and will mount the partition with a 'noexec' option.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.