Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

(I did quite a bit of messing around before asking for help, which in retrospect was a mistake, so the BootInfo might be more useful than my retelling of the events: http://paste.ubuntu.com/5659500/)

So, I had been using Windows 8 for several months, as it came with my new laptop (a Lenovo Ideapad Y400), but I decided to try out Ubuntu with a dual-boot setup. Ubuntu 12.04 simply wouldn't boot properly off the liveUSB (and I still can't get it to work), so I got 13.04.

I installed it using the default option for a dual-boot setup, and it worked quite well, but I could never boot Windows 8 from grub, which was a minor hassle. I now think that going into the BIOS and deactivating Secure Boot might have fixed it, but at the time, I simply got Boot-Repair and ran it in Recommended Repair mode. But then Windows wouldn't boot at all, telling me there was an error with Windows Boot Manager, and Ubuntu was blocked by security settings or something. I used the recovery partition that came with the laptop and restored Windows 8 to its factory condition.

Since then, I tried installing Ubuntu again with a few different partition schemes (formatting everything but the main Windows 8 partition and the other default partitions made by Windows 8 and Lenovo), but no matter what, Ubuntu won't actually boot. Grub works, but when I choose to boot Ubuntu, it fails. It also gives me the same error as before when I try to boot Windows 8 from grub.

I think I might run boot-repair's recommended repair again, but seeing as it seems to have created some issues the first time around, I thought it best to ask for help first.

share|improve this question
    
Have you already looked at askubuntu.com/questions/221835/… ? –  belacqua May 13 '13 at 3:11
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.