Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I see that there have been other similar posts, but the underlying problems seem to vary. I am not competent to troubleshoot myself, could you please walk me through it:

I have recently upgraded from 10.04 to 12.04 working under GNOME. The installation is fine (with occasional "internal errors") when I specify GNOME Classic at logon, but gnome-shell does not load (even though installed). It does load when I specify GNOME at login.

So it seems that GNOME fallback is running even though I specify GNOME Classic?

If possible I would like to have GNOME Classic with gnome-shell working to be able to use Gnome extensions.

Looking forward to your advice, thanks so much, John

P.S. I noticed that when I originally intalled GNOME I followed web advice to install only gnome-session-back, and later installed gnome-shell. To be sure that was not the problem, I completely disinstalled gnome-session-fallback and gnome-shell, then rebooted in Unity and installed gnome-shell (which also installs automatically gnome-session-fallback). Same result: when loggin in with GNOME Classic, gnome-shell does not load and I apparently get a GNOME fallback session. Sometimes (maybe 10%) I get session with no top and bottom task bars (representing failed GNOME Classic?); in that case I close and reopen the session specifying GNOME Classic and I get a perfectly useable interface without gnome-shell loaded.

share|improve this question
4  
Gnome Classic is the Fallback session, Gnome is Gnome Shell. –  Uri Herrera May 12 '13 at 22:24
    
No. Gnome Classic is replacing Fallback, fallback did not run the shell where as Gnome Classic is just Gnome Shell with extensions to reproduce the appearance of Gnome Fallback, since fallback is being removed. According to the original notes this new mode is to be called Legacy, but it is explained in more detail here: blogs.gnome.org/mclasen/2012/12/05/… –  l300lvl May 13 '13 at 1:47
    
@John Rose: Can you try creating a new user and logging into gnome shell? I have had many problems solved by just creating a new user, also what graphics are you using, intel/amd-ati/nvidia and what driver? With amd-ati after certain updates sometimes it helps to uninstall with aticonfig --uninstall and then reboot into a working gnome shell and reinstall the graphics drivers. –  l300lvl May 13 '13 at 1:56
    
You must be using Gnome 3.9.1 right? then this problem might happen. Because according to me Gnome 3.9.1 is compatible with 13.04 –  SRJ May 13 '13 at 5:34
    
srj do you mean 3.8.1? Not to be off topic but how would one install 3.9.1 I would like to test it out. –  l300lvl May 13 '13 at 6:46
show 3 more comments

Know someone who can answer? Share a link to this question via email, Google+, Twitter, or Facebook.

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.