Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This relates to Kubuntu 13.04. It is a clean install into a clean /home folder. When I launch kmail the CPU usage of the virtuoso-t process increases by a huge amount.

I have an i5 laptop and the usage of that process before kmail is launched is below 1% a few moments after kmail is launched the process usage shoots up to 150%+ (so atleast one and a half cores are being maxed by the virtuoso-t process...). If this settled after a few hours it would be ok, but it doesn't seem to settle down and there is no clear way of seeing what is being done or if it is only a zombied thread inside virtuoso.

Being a laptop this of course completely destroys battery life. The sad thing is that I mainly use the laptop for email (due to it being mobile) while on the road and as such needs the auto complete of contact's email address and the semantic features.

Is there a way to determine if this process is indeed zombified and looping or if it is actually indexing the email. But what confuses me is why would nepomuk only want to index emails when kmail is open? Surely it has access to the local email headers in the same way kmail has??

Kind regards,

George

share|improve this question
add comment

2 Answers 2

Disable email indexing. I had the same issue and went away when I disabled email indexing. My guess is that if you have a lot of emails (e.g. Gmail with lots of email archived in "All Mail") it takes a long time to index their contents.

To disable this, go to Nepomuk Server Configuration and uncheck "Enable Email Indexer" under Email Indexing.

share|improve this answer
add comment

I have noticed the same on my ASUS K72F laptop while absolutely no such trouble on i7 desktop PC I use as well. After lots of trials & errors I found a combination that seems to mitigate such a naughty behavior of Nepomuk/Virtuoso.

  • Make sure you have enabled and launch running Nepomuk Search Module in System Settings->Services Manager (you find it in a lower pane)

  • Also, make sure you cleaned Nepomuk DB (either delete ~./kde/share/apps/nepomuk or run $>nepomukcleaner

  • You can kill greedy nepomukstubs and/or virtuoso-t processes and then re-enable them in System Settings

  • you may benefit to restart Akonadi server by $> akonadictl restart

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.