Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Last night I was installing FlightGear 2.10 on my Ubuntu 13.04 sytem. I added the plydeb package, etc. and got ubuntu software center to see the 2.10 FlightGear version. I left it to download and install overnight, and came the next morning to this warning:

An error occurred. Please run the Package Manger form the right-click menu or apt-get in a terminal to see what is wrong.

The error message was:

 'Error:BrokenCount>0'. This usually means that your installed packages have unmet dependencies."

I used Synaptic to uninstall the error-causing flightgear(fgfs) with the "broken" filter, and then did a sudo apt-get remove fgfs*, which got rid of flightgear (at least the games folder is /usr/share/).

However, now Ubuntu Software Center won't launch. I click on it and it pops up with it's dotted circle in the middle, showing that it's thinking. After a few seconds its white background turns a darker colour, showing that it froze. It does not recover from this frozen state. Doing software-center in the terminal gives:

2013-05-12 14:44:51,328 - softwarecenter.ui.gtk3.app - INFO - setting up proxy 'None'
2013-05-12 14:44:51,632 - softwarecenter.plugin - INFO - activating plugin '<module          'webapps_activation' from '/usr/share/software-  center/softwarecenter/plugins/webapps_activation.pyc'>'
2013-05-12 14:44:51,635 - softwarecenter.fixme - WARNING - logs to the root logger: '('/usr/lib/python2.7/dist-packages/gi/importer.py', 51, 'find_module')'
2013-05-12 14:44:51,635 - root - ERROR - Could not find any typelib for LaunchpadIntegration
2013-05-12 14:44:51,679 - softwarecenter.db.pkginfo_impl.aptcache - INFO - aptcache.open()

When I try reinstalling using sudo apt-get purge software-center and then sudo apt-get install software-center, I get:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  freeglut3 kde-l10n-engb libalut0 libplib1
Use 'apt-get autoremove' to remove them.
The following packages will be REMOVED:
  software-center*
0 upgraded, 0 newly installed, 1 to remove and 0 not upgraded.
After this operation, 3,588 kB disk space will be freed.
Do you want to continue [Y/n]? Y
(Reading database ... 257891 files and directories currently installed.)
Removing software-center ...
Purging configuration files for software-center ...
Processing triggers for man-db ...
Processing triggers for bamfdaemon ...
Rebuilding /usr/share/applications/bamf-2.index...
Processing triggers for desktop-file-utils ...
Processing triggers for gnome-menus ...
Processing triggers for hicolor-icon-theme ...

and I also get:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  freeglut3 kde-l10n-engb libalut0 libplib1
Use 'apt-get autoremove' to remove them.
The following NEW packages will be installed:
  software-center
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/443 kB of archives.
After this operation, 3,588 kB of additional disk space will be used.
Selecting previously unselected package software-center.
(Reading database ... 257427 files and directories currently installed.)
Unpacking software-center (from .../software-center_5.6.0-0ubuntu2_all.deb) ...
Processing triggers for hicolor-icon-theme ...
Processing triggers for bamfdaemon ...
Rebuilding /usr/share/applications/bamf-2.index...
Processing triggers for desktop-file-utils ...
Processing triggers for gnome-menus ...
Processing triggers for man-db ...
Setting up software-center (5.6.0-0ubuntu2) ...
Updating software catalog...this may take a moment.
INFO:softwarecenter.db.pkginfo_impl.aptcache:aptcache.open()
WARNING:softwarecenter.db.update:The file: '/usr/share/app-install/desktop/sonic-visualiser:x-sonicvisualiser.desktop' could not be read correctly. The application associated with this file will not be included in the software catalog. Please consider raising a bug report for this issue with the maintainer of that application
WARNING:softwarecenter.db.update:The file: '/usr/share/app-install/desktop/sonic-visualiser:x-sonicvisualiser-layer.desktop' could not be read correctly. The application associated with this file will not be included in the software catalog. Please consider raising a bug report for this issue with the maintainer of that application
WARNING:softwarecenter.db.update:The file: '/usr/share/app-install/desktop/workrave:workrave.desktop' could not be read correctly. The application associated with this file will not be included in the software catalog. Please consider raising a bug report for this issue with the maintainer of that application
Software catalog update was successful.

I appreciate any help to try and get software center working again!

share|improve this question
    
I fixed the error with the command: sudo rm -r ~/.cache/software-center/ Thank you to Alex for tidying up my first post! :) –  Daniel M May 12 '13 at 13:34
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.