Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I use Ubuntu 9.04 (the most recent version that the VPS host provided) on a Xen VPS. The kernel version seem to be something Xen-specific: 2.6.18-194.32.1.el5xen.

I would like to have the most recent version of Ubuntu Server, 10.10. Can I upgrade my VPS to 10.10 or do I need to stay with this version because it seem to be a Xen-specific kernel?

share|improve this question
add comment

2 Answers

up vote 1 down vote accepted

Whether or not you "Can" (Derek seems to have shown that its possible), its not supported officially.

To be sure all of the corner/special cases are handled, what you will need to do is upgrade through the two releases between.. 9.10 and 10.04.. before you get to 10.10.

This is pretty simple, just run

sudo do-release-upgrade

This will perform all necessary actions to get to 9.10. Then reboot, and go to 10.04, then 10.10.

Definitely do so soon, 9.04 has not had security updates since October 2010, and 9.10 will stop receiving updates in April of 2011 (as of this writing, next month). Unless you really need something in 10.10, its a decent idea to stop at 10.04, since that way you won't be forced to upgrade for another 4 years from now (its supported for 5, and came out about a year ago).

share|improve this answer
    
I tried do-release-upgrade and it rebooted. But I wasn't able to login via SSH anymore, so I had to use "re-install OS" from my VPS control panel. In other words, it didn't work. –  Jonas Mar 9 '11 at 11:05
    
sounds like your VPS provider has done something wonky.. do they let you get access to the console output? I'd be curious to hear what went wrong that ssh didn't start, as quite a bit of care is taken to make sure that happens on every upgrade for this very reason. –  SpamapS Mar 14 '11 at 17:25
    
Just ran the same test on an ubuntu AWS, fresh copy of 9.10 to 10.4. I believe SSH doesn't start. I have the system log if anyone is interested –  Jason May 21 '12 at 10:41
add comment

I have a Xen HVM VPS, and I am able to install whatever operating system I want as long as I have the ISO for it. I downloaded the Ubuntu 10.10 minimal ISO for 32-bit and it worked fine. I didn't seem to need a Xen-specific iso.

share|improve this answer
    
I don't have an Xen HVM VPS, but an Xen VPS. I am not asking about installation, but upgrading. –  Jonas Mar 9 '11 at 11:03
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.