Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

as described here dell 7520 (inspiron 15R SE), fan on full speed on 12.04, 12.10, 13.04, i still have problems with my energy comsumption and fan noise under ubuntu 13.04. i could reduce it to a minimum though with the following entries in /etc/rc.local like described How to permanently switch off discrete graphic card?

 echo OFF > /sys/kernel/debug/vgaswitcheroo/switch
 echo "min_power" | sudo tee /sys/class/scsi_host/host*/link_power_management_policy

the first command reduces battery consumption, the second one reduces fan noise. the entry in the rc.local makes sure to run the commands at startup. so far, so good.

from time to time it is necessary to run the 2nd command again to silence the fans, for example after plugin the ac power or after resume. also after resume the discrete graphics card is running again.

my question now:

  • how can i make script or button to run the two commands as user with root rights without doing all that typing work in a terminal all the time, as a shortcut for example?
  • is there a more elegant solution so solve that issue?

By the way, if that is of any help. it seems like the fans start spinning immediately and together with minimum rise of cpu usage

share|improve this question
1  
askubuntu.com/questions/285434/… –  Qasim May 12 '13 at 11:54
    
you are welcome .. if this link solve your issue you can flag it as duplicate –  Qasim May 16 '13 at 9:40
    
i tried tlp and with some options suggested there i got a much quieter computer. although its running in "powersave mode" even with AC plugged in, which makes it kind of slow, because it cuts off alot of its potential power. it is not the best solution, is like tuning down a formular one car to the speed of a whatever much slower car...anyways, until there arent any better kernels or driver solutions i keep it this way. –  zanza May 16 '13 at 9:45
    
i am also using powersave on ac/bat ...why ? cauzz the place i like in its very hot here & its getting hotter day by day ..& most of the time i usually browsing, watching movies etc ...so powersave is fine with me ...but when i use visualization i switch to on demand mode ..that is y i have listed indicator-cpufreq there, so you can change the when you need more power ... –  Qasim May 16 '13 at 9:51
    
check my answer askubuntu.com/questions/293426/… –  Qasim May 16 '13 at 9:52
add comment

1 Answer

If the power consumption is only due to excessive fan speed, you can also adjust that using i8kfan/i8kmon (from i8kutils package).

By default i8kmon is just a window with one button for changing fan speed, but it can also be run as a daemon with customizable temperature thresholds.

To me it's still a mystery that Ubuntu runs the fan at the very noisy max speed by default if you don't do the above...

share|improve this answer
    
I think the OP of the question does not have the same issue as you have. As described in the question, lowering the power policy of the GPU the fan speed will go down - so fan speed adjustment is working fine for him. If you have a different question for your hardware, please use the "Ask Question" button at the top of the page. –  gertvdijk Jun 20 '13 at 8:26
    
I haven't read the question properly but i8kmon is an AWESOME tool to control the fan speed specially on dell inspiron machines and should be spread. +1 –  Muhammad Gelbana Feb 4 at 20:35
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.