Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have just installed Ubuntu 13.04 Raring. Now I'm facing a problem with my Huawei EC156 modem.

At first it will work properly but it will disapear from network-manager if the modem is disconnected after online or removed from the USB slot. The 'Enable Mobile Broadband' would also disappear from Network Manager. The modem will appear again if I use it from Windows and then run it again on Ubuntu.

If the modem is detected correctly, dmesg would show something like this:

New USB device found, idVendor=12d1, idProduct=140c

but if it is not detected, dmesg would show this result:

New USB device found, idVendor=12d1, idProduct=1505

I have never seen this problem before in previous versions of Ubuntu. How can I fix it?

share|improve this question

2 Answers 2

Probably you could have tried what i'm about to say.

lsusb

usb-devices

The above commands will list the usb-devices plugged in to your machine.

However the following method works charm for me every time. Plug the usb device before you turn on your laptop.

After login, please enter the following commands in your terminal:

dmesg -c

Please note down the prints that your modem is detected.

lsusb

And get your device's vendor & product id.

modprobe option

service network-manager restart

echo 12D1 140C > /sys/bus/usb-serial/drivers/option1/new_id

dmesg

Now you must see some changes in dmesg detecting your usb device as a modem. If not, after dmesg -c, try modprobe -r usb_storage which will remove the support for usb storage devices. Sometimes your modem gets detected as usb storage. After your modem is detected, you can re-enable usb storage by modprobe option.

Hope this will help.

share|improve this answer
up vote 0 down vote accepted

I have found the answer from this blog. It's in Indonesian, so I'd like to translate and explain it a little bit.

All you need is two simple step:

  1. Write a file for usb_modeswitch:

    # nano /etc/usb_modeswitch.d/12d1:1505
    

    Fill the file with these text:

    DefaultVendor= 0x12d1 
    DefaultProduct=0x1505 
    MessageContent="55534243123456780000000000000011062000000100000000000000000000"
    
  2. Issue command:

    # usb_modeswitch -I -W -c /etc/usb_modeswitch.d/12d1:1505
    

Now the modem should has changed its mode and can be detected by NetworkManager.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.