Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Software center won't start unless I run it as root. Running it as root, there was a message about the cache being unwritable. My .cache folder is on a separate drive and symlinked to my home directory. Interestingly, software center seemed to be working after that. I think it broke after I installed Pidgin.

Here is the terminal output when I try to run software center as myself

winobes@epoch:~$ software-center
2013-05-11 19:53:54,872 - softwarecenter.ui.gtk3.app - INFO - setting up proxy 'None'
2013-05-11 19:53:54,881 - softwarecenter.fixme - WARNING - logs to the root logger: '('/usr/share/software-center/softwarecenter/db/database.py', 204, '_get_new_xapiandb')'
2013-05-11 19:53:54,881 - root - WARNING - failed to add sca db Couldn't detect type of database
2013-05-11 19:53:54,958 - softwarecenter.fixme - WARNING - logs to the root logger: '('/usr/lib/python2.7/dist-packages/dbus/proxies.py', 410, '_introspect_error_handler')'
2013-05-11 19:53:54,957 - dbus.proxies - ERROR - Introspect error on com.ubuntu.sso:/com/ubuntu/sso/credentials: dbus.exceptions.DBusException: org.freedesktop.DBus.Error.Spawn.ChildExited: Process /usr/lib/ubuntu-sso-client/ubuntu-sso-login exited with status 1
Traceback (most recent call last):
  File "/usr/bin/software-center", line 130, in <module>
    app = SoftwareCenterAppGtk3(options, args)
  File "/usr/share/software-center/softwarecenter/ui/gtk3/app.py", line 338, in __init__
    self.icons)
  File "/usr/share/software-center/softwarecenter/ui/gtk3/session/appmanager.py", line 66, in __init__
    self.oauth_token = helper.find_oauth_token_sync()
  File "/usr/share/software-center/softwarecenter/backend/ubuntusso.py", line 141, in find_oauth_token_sync
    sso.find_credentials()
  File "/usr/share/software-center/softwarecenter/backend/login_impl/login_sso.py", line 75, in find_credentials
    self.proxy.find_credentials(self.appname, self._get_params())
  File "/usr/lib/python2.7/dist-packages/dbus/proxies.py", line 70, in __call__
    return self._proxy_method(*args, **keywords)
  File "/usr/lib/python2.7/dist-packages/dbus/proxies.py", line 145, in __call__
    **keywords)
  File "/usr/lib/python2.7/dist-packages/dbus/connection.py", line 651, in call_blocking
    message, timeout)
dbus.exceptions.DBusException: org.freedesktop.DBus.Error.Spawn.ChildExited: Process /usr/lib/ubuntu-sso-client/ubuntu-sso-login exited with status 1

And When I run as root:

winobes@epoch:~$ sudo software-center
[sudo] password for winobes: 
2013-05-11 19:55:20,352 - softwarecenter.ui.gtk3.app - INFO - setting up proxy 'None'
2013-05-11 19:55:21,000 - softwarecenter.backend.reviews - WARNING - Could not get usefulness from server, no username in config file
2013-05-11 19:55:21,002 - softwarecenter.plugin - INFO - activating plugin '<module 'webapps_activation' from '/usr/share/software-center/softwarecenter/plugins/webapps_activation.pyc'>'
2013-05-11 19:55:21,005 - softwarecenter.fixme - WARNING - logs to the root logger: '('/usr/lib/python2.7/dist-packages/gi/importer.py', 51, 'find_module')'
2013-05-11 19:55:21,005 - root - ERROR - Could not find any typelib for LaunchpadIntegration
(software-center:28600): IBUS-WARNING **: The owner of /home/winobes/.config/ibus/bus is not root!
2013-05-11 19:55:21,044 - softwarecenter.db.pkginfo_impl.aptcache - INFO - aptcache.open()
2013-05-11 19:55:23,322 - softwarecenter.ui.gtk3.widgets.exhibits - WARNING - download failed: '<class 'gi._glib.GError'>', 'Operation not supported'
2013-05-11 19:55:29,214 - softwarecenter.db.utils - INFO - software-center-agent finished with status 0

Software center seems to work when I run with sudo, At least it launches. But it makes me kind of nervous, and I'd like to be able to use the launcher...

Things I have tried:

sudo chown winobes ~/.cache

sudo chown winobes ~/.cache/software-center

sudo apt-get install --reinstall software-center

Thanks for your help and insight :)

share|improve this question

1 Answer 1

up vote 1 down vote accepted

Do'oh!

sudo chown winobes ~/.cache

obviously just changes the owner of the symlink....

sudo chown winobes /mnt/data/.cache

fixed my problem.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.