Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm on Ubuntu 10.04.2 LTS Desktop. (And by scanning /boot, it appears I might be on kernel 2.6.32-29-generic? Not certain.)

Anyway, after my last system update, now my screen lock asks me to login twice, whereas before it did not require this.

I assume this is a bug? And is there a way to undo this for now until the bug is fixed?

share|improve this question
    
Do you mean what happens when you click lock screen from the system menu? Or are you switching users? –  RolandiXor Mar 7 '11 at 16:22
1  
I have my screensaver set to do a screen lock when idle. When I wiggle my mouse, I see the login for the screen lock. I type in my password, and then it goes black and asks me yet again. Clearly this is a bug with the latest Ubuntu update because that's the only thing major I've really done. It just started occurring yesterday after my most recent Ubuntu update. –  Volomike Mar 7 '11 at 19:52
    
For now, I have turned off my screen lock in the screensaver. I hate that, though. I highly value my screen lock. –  Volomike Mar 7 '11 at 19:53
    
I have this issue too. When the machine is idle and the locking screensaver active, and the password is entered, the desktop appears as it should but only for about a second, then it goes back to being screensaver locked. On the second try it is unlocked. My Linux Mint (ubuntu 10 based) on an ASUS eeePC did this for a while intermittently. Have you tried doing an apt-get upgrade to see if someone else has posted fixes? –  Paul Mar 7 '11 at 23:33
    
@Paul. Tried doing the "apt-get update; apt-get upgrade", and that didn't work. Rebooted. Didn't work. Tried more apt upgrades. Didn't work. Also, I'm only doing a screen dim -- no screensaver. And when I turned off the screen lock, I get this problem where I can't type anything in Chrome and must shut down Chrome and come back again. –  Volomike Mar 9 '11 at 18:21
add comment

1 Answer

up vote 0 down vote accepted

After enough updates with "sudo apt-get update; sudo apt-get upgrade" and reboots, Ubuntu finally must have fixed this bug because I no longer have to login twice after a screen lockout timer engages from the screensaver. Also, it used to be that Chrome would lockup on the keystrokes after unlocking a screen, but that problem went away as well. Also, I appear to still be on the same kernel as when the problem occurred: kernel 2.6.32-29-generic.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.