Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I attempt to run Vim from a terminal, I get the following error:

vim: symbol lookup error: vim: undefined symbol: init_hashlib

I did some searching and the general consensus is that this is related to a a dependency on Python version 2.7.3 that is broken under Python 2.7.4 (which is the version installed under Ubuntu 13.04).

Not sure what approach to take here. I thought maybe I could remove Python version 2.7.4 and install version 2.7.3, but from what I've read, it's dangerous to mess with python, and there may be dependencies on Python version 2.7.4 that are essential to Ubuntu 13.04.

I tried uninstalling vim and re-installing via apt-get, no luck. Anyone have any ideas?

share|improve this question
    
I have no problems with Vim or GVim. Have you tried reinstalling... Python!? –  espectalll123 May 11 '13 at 18:39
    
@espectalll123 I don't want to uninstall python because it's integral for the desktop GUI. I guess I could shut down X and do it from pure terminal... –  acepukas May 11 '13 at 19:50
    
Resolved this by installing Python 2.7.3 locally and compiling Vim from source, specifying the python config/lib directory. Should not have to do this! –  acepukas May 13 '13 at 14:50
add comment

Know someone who can answer? Share a link to this question via email, Google+, Twitter, or Facebook.

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.