Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I use an Acer 4750 laptop, which has a bcm43225 wifi chip. In Ubuntu 12.04, each time I boot up, my laptop's wifi will automatically turn on, and the 12.04 use kernel 3.2 However, when I upgraded to 12.10, 13.04, using a newer kernel, I found my wifi not automatically turning on during startup. But its function is normal:I still can turn on it with Fn key.

I have experimented it, using a 3.9 kernel in Ubuntu 12.04, it was the same situation, won't turn on during boot but can be switch on with Fn key.

I have checked the rfkill list, no device was blocked

So, how do I make my wifi automatically turn on with newer kernel? It will be more convenient for me~~

Ps:I'm using bcmwl-kernel-source

share|improve this question
add comment

2 Answers

Try this commands in terminal.
sudo apt-get install linux-headers-generic
sudo apt-get install --reinstall bcmwl-kernel-source
sudo modprobe wl

share|improve this answer
add comment

Try these

sudo apt-get remove --purge bcmwl-kernel-source

sudo apt-get install linux-firmware-nonfree

From this threaed --> http://ubuntuforums.org/showthread.php?t=1997880.
I skipped the first command and still worked.

This works for me.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.