Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am running Ubuntu 13.04 64-bit on an Asus UX31A. To control the default screen and keyboard brightness after the start, I wrote this to the rc.local:

echo 0 > /sys/class/backlight/acpi_video0/brightness
#echo 0 > /sys/devices/platform/asus-nb-wmi/leds/asus::kbd_backlight/brightness
exit 0

The screen brightness is perfectly adjusted after every restart, but the keyboard backlight won't work. It's always at 100% and if I uncomment the second line the screen brightness won't work, too. Seems like the permission is denied or the script can't access the file, because the path is totally correct.

Any tips?

share|improve this question
    
Tried kernel boot parameters like acpi_osi='!Windows 2012', acpi_osi=Linux, acpi_osi=, and/or acpi_backlight=vendor? –  GM-Script-Writer-62850 May 11 '13 at 14:43
    
Well, atleast one: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash pcie_aspm=force drm.vblankoffdelay=1 i915.semaphores=1 acpi_osi='!Windows 2012'" Should I try the others, too? –  Andrew May 11 '13 at 15:15
    
Any 1 of the 4 i listed the last one can be combined with the 1st 3, for the most part this is trail and error, don't forget to run update-grub after making the change, reboot should be obvious –  GM-Script-Writer-62850 May 11 '13 at 15:28
    
Nope, none of them worked for me. I tried some combinations but without success. Maybe one entry like drm.vblankoffdelay=1 i915.semaphores=1 is the problem? –  Andrew May 11 '13 at 15:41

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.