Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just installed Ubuntu 13.04, and there is a problem with my wired internet connection.

The weird thing is that it's not a driver problem, i guess, because it connects to my router, but does not receive any response from other servers. The internet works just fine in Windows 7, or on my phone.

Here is a screenshot :

enter image description here

I have a Dell Optiplex GX270, and a Serioux SRX-WR150WH wifi router.

/// EDIT

Here are the ouputs for cat /etc/resolv.conf :

Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
nameserver 127.0.1.1
search SRX

and for route -n :

Kernel IP routing table Destination Gateway Genmask Flags Metric Ref Use Iface
0.0.0.0 192.168.1.1 0.0.0.0 UG 0 0 0 eth0
169.254.0.0 0.0.0.0 255.255.0.0 U 1000 0 0 eth0
192.168.1.0 0.0.0.0 255.255.255.0 U 1 0 0 eth0

Also, here is a screenshot with my Connection Information, and the output of ping 8.8.8.8, which just goes on forever (I stopped it at around 430) :

enter image description here

Thanks.

PS I also tried running Ubuntu 13.04 liveUSB on my old laptop, and had the same results as with the computer, it connected to my router, but had no internet at all. Outputs are the same.

share|improve this question
    
Open a terminal (Ctrl+Alt+T), and edit your answer to include the outputs of these commands: cat /etc/resolv.conf and route -n. –  Alaa Ali May 13 '13 at 17:48
    
May be a DNS issue. From the Network Connection icon in the menu bar, select 'Connection Information' - what are the properties there? –  douggro May 14 '13 at 13:10
    
to check if DNS is the problem, go to the console (CTRL+ALT+T) and do a ping 8.8.8.8 (the IP is one of Google's open DNS servers) –  Silviu May 14 '13 at 13:19
    
Seems your DNS settings are bad. Please check them. To check the DNS server settings, ping a URL like ping www.ubuntu.com –  charlie May 14 '13 at 14:02
    
Go to network manager > edit your connection > use static settings & check if it solve the problem example use ip 192.168.1.25 , netmask 255.255.255.0 , gateway 192.168.1.1 , dns 8.8.8.8 and 8.8.4.4 –  Qasim May 14 '13 at 14:04

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.