Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm currently running ubuntu 13.04 64 bit on a custom computer. Today I upgraded my mobo, cpu and memory. My old configuration was asus a8n-sli deluxe mobo and a AMD athlon 64 FX-60 Dual Core processor x 2 with 4 gb ram. My new configuration is gigabyte 990fxa-ud3 motherboard, a AMD fx-8350 cpu with 16gb ram. Everything else stayed the same (ie hard drive, gpu, etc.) except I removed the sound card and both DVD drives because they were outdated. After installing the new hardware I tried to boot linux from my HDD and got this screen: GNU GRUB version 2.00-13ubuntu3 with 4 options: ubuntu, advanced options for ubuntu, memory test (memtest86+), memory test (memtest 86+, serial console 115200)

When selecting ubuntu, i get this: Gave up waiting for root device. Common problems: -Boots args (cat /proc/cmdline) - Check rootdelay= (did the system wait long enough?) - Check root= (did the system wait for the right device?) -Missing modules (cat /proc/modules; 1s /dev ALERT! /dev/mapper/ubuntu--vg--root does not exist. Dropping to a shell! BusyBox v1.20.2 (Ubuntu 1:1.20.0-8ubuntu1) built in shell (ash) Enter 'help" for a list of built in commands.

(initramfs)_

I can't enter help on that screen, the keyboard doesn't seem to work.

Any help would be greatly appreciated.

share|improve this question
    
It is probably due to the change from bios to uefi, in the off chance secure boot is enabled on the new motherboard disable it; Also can you run the bootinfoscript if that is not the case –  GM-Script-Writer-62850 May 11 '13 at 1:50
    
Can you boot a live session from USB/CD? –  Takkat May 11 '13 at 6:58
    
Sorry, somehow I accidentally made 2 accounts. Anyway, didn't find secure boot in the gigabyte -uefi dualbios, I also downloaded and searched the manual and secure boot wasn't in the manual. Is it called something else possibly? Does the legacy vs uefi have something to do with it? tried "try ubuntu without installing" and received this message again: BusyBox v1.20.2 (Ubuntu 1:1.20.0-8ubuntu1) built in shell (ash) Enter 'help" for a list of built in commands. –  Pichard Rarker May 11 '13 at 7:39
    
@PichardRarker - please click the contactus button at the bottom of this page and ask for your accounts to be merged. Once done, you'll be able to edit your question with responses to comments such as the above. Thanks. –  fossfreedom May 11 '13 at 21:27
    
somewhere in the bios it will likely have a option that is set to UEFI, that can be set to BIOS, probably in the boot section; you can try boot repair –  GM-Script-Writer-62850 May 11 '13 at 21:43

2 Answers 2

To recover your keyboard set on BIOS IOMMU = yes (it is disable by default). It is already reported with this mobo as a fix for USB2 and network problems

share|improve this answer

Due to the motherboard change your disks might have been renamed (or they are not found!). Here's how I would proceed:

  1. Reboot using the Ubuntu stick, select "Recovery Mode" in the boot menu. If you don't have that option, get the "Alternate Install" CD from Ubuntu.
  2. Ensure that your harddisk(s) and partitions are found by Ubuntu. See also http://members.iinet.net/~herman546/How-To-Rescue-a-Broken-System.html
  3. Reinstall the GRUB boot loader. If you don't have any other OS installed it should be safe to install it directly on your harddisk.
  4. Try rebooting.

Good luck!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.