Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am on a wired dsl, pppoe connection which is properly set, but the problem is that is shows that is connected but there is no internet at all.

I thought that the problem was the ipv6 and I managed to disable it, but now in NM the eth0 ipv4 address is 0.0.0.0. I don't know what the problem is :) , weird.

I also edited the interfaces file by adding the new interface auto eth0 and setting it to be dhcp. I restarted the dhcp server and got some errors I think, it says "no leases ..." whatever.

Any ideas what the problem could be? Why it is not giving me ip address?

It is weird that when I work with my wireless there is no problem, it connects auto and the internet is just fine.

share|improve this question
3  
Could you provide a bit more detail? How did you set up the PPPoE connection in the first place? What exactly are the errors you're getting? What is the output of ifconfig -a? Thank you –  Stefano Palazzo Mar 7 '11 at 11:24
    
ok, I am setting my connection in network manager in the dsl tab. I set my username and pass from my ISP and click aply. After that it connects auto and says that is connected but when I open network tools in admin menu, the ipv4 address is 0.0.0.0 Here is my dhcp errors: DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 4 No DHCPOFFERS received. No working leases in persistent database - sleeping. Will get back shorlty for the sudo route command –  user11963 Mar 8 '11 at 11:31

1 Answer 1

You didn't mention whether you are using a router or not. You mentioned it works when you use wireless, which I presume is done through a router. If you plug into the wired port on the same router, it should work the same way. If you are not using a router, then it is normal for eth0 to not have an address. Instead pppoe ( which is a terrible protocol by the way, so if you have a choice, switch to an ISP that doesn't use it ) creates another interface when you "dial up" and that interface gets the address.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.