Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I know there are a lot of questions like this here, but I tried them all and I couldn't make them work.

  • I have a HP dv6-2190ep laptop.

  • My sound card is HDA Intel IDT 92HD75B3X5.

  • My Ubuntu is 13.04.

I tried to add options on alsa-base.conf but I still don't have auto mute option.

I'm completely changing to Ubuntu from Windows and it is important to fix this. I'm around this for about 1 month.

share|improve this question
1  
Hi, I just resolved my problem following the steps provided here: wiki.ubuntu.com/Audio/UpgradingAlsa/DKMS –  Alex Sep 9 '12 at 18:41
    
I followed that link and my problem solve too, thank you. –  Saeed Zarinfam Sep 14 '12 at 17:27
    
Did you check Sound Troubleshooting Procedure? –  Mohammad Etemaddar Apr 29 '13 at 7:23
    
It would help if you could add the model # of the laptop to your question! –  Jorge Castro Apr 29 '13 at 20:29
    
What audio card do you have? (alsamixer) –  Seth May 2 '13 at 16:40

7 Answers 7

Try removing pulseaudio completely and installing alsa.

Check this out

Remove Pulse Audio

sudo apt-get autoremove pulseaudio

Reboot your computer or stop the pulseaudio daemon.

Install alsa-mixer

sudo apt-get install gnome-alsamixer

If you don't get any sound output run

gnome-alsamixer

For more details go to How to Remove PulseAudio & use ALSA in Ubuntu Linux?

share|improve this answer
2  
Welcome to Ask Ubuntu. Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. –  Peachy Sep 8 '12 at 12:42
    
I now get no sound in my ubuntu 14.04!! This is the first time I have ever had problems with sound what is going on!! –  uzi3k Jun 22 at 10:56

I have had this problem on my Asus K55vm laptop since 12.04. Although your solution does work, in laptops it will cause the sound to be transmitted by both the plugged headphones and the speakers. To make them work properly and only have sound come out of the headphones when plugged in or the speakers when headphones are not plugged in:

Run in terminal:

sudo gedit /usr/share/pulseaudio/alsa-mixer/paths/analog-output-headphones.conf

Find:

[Element Headphone]

Set it as:

[Element Headphone]
required-any = any
switch = on
volume = zero
override-map.1 = all
override-map.2 = all-left,all-right

Find:

[Element Desktop Speaker]

Set it to:

[Element Desktop Speaker]
switch = on
volume = zero

This works FOR ME BUT: keep in mind that when you plug in your headphones their volume will be the volume they were the last time and when you unplug them the speakers volume will be the volume it was before you plugged in the headphones.

I hope this can also help someone with the same problem as me and thank you very much bozbezbozzel! Without you I would not have made it. :)

share|improve this answer
    
Thank's, very good solution. For me work perfectly Ubuntu 12.04 with card HDA Intel. –  Davide Mar 13 at 19:42

If you are running close to a vanilla install of Ubuntu 12.04LTS, try sudo apt-get update and sudo apt-get update --fix-missing. Now I know those are very novice answers, but it may just work. My last suggestion is to go to this answer: When I plug in headphones, my speakers mute, but nothing comes from the headphones which is loosely related to the issue you are having. If this doesn't help, try going to the audio options in system settings and make sure you have the correct output selected.

share|improve this answer
  1. Go to this page.
  2. Under the "Source label", check which DKMS package that is corresponding to your current distribution series (in this case precise) and click the leftmost arrow to expand that section.
  3. Under the new section "Package files", click the file ending with ".deb", download and install it by executing execute this command: sudo dpkg -i <file name>.
  4. Reboot.

Further information.

share|improve this answer

this should work click the link How do I change which audio jacks are used for input and output? and this should work for the new 13.04 Python script to change the jack from input to output does not work in 13.04

share|improve this answer
    
Thanks for the quit answer and this does help a bit, but not as expected. I identified the PIN and enabled "out", but sound appears only for a second and goes silent again –  user1228633 May 2 '13 at 16:49
    
try saving it look on the askubuntu.com/questions/225017/… link and it tells you how to save it do not revert it when done just click no –  Scott Hunt May 2 '13 at 16:56
    
Thank you for your help, it needed a reboot and some try and error, but now it works. The only thing, which isn't perfect now is, that settings->sound cannot switch between headphones/speakers. But this is okay, since I exported 2 scrips for enabling / disabling headphones / speakers :) –  user1228633 May 2 '13 at 22:02

I had the same issue. This worked for me.

Try this:

Go to: /etc/pulse/default.pa and comment out the following line with a # sign:

load-module module-switch-on-port-available
share|improve this answer

I've got an HP Pavilion dv6 with beats audio, and I had the exact same problem. Alsamixer muted the 'Speaker' volume when I plugged my headphones in, and apparently, that is the volume the headphones use. I found the following workaround:

sudo gedit /usr/share/pulseaudio/alsa-mixer/paths/analog-output-headphones.conf

You'll find the line:

[Element Speaker]
switch = off
volume = off

Change it to:

[Element Speaker]
switch = on
volume = merge

Now, do the same with usr/share/pulseaudio/alsa-mixer/paths/analog-output-headphones-2.conf and reboot. Now your headphones should work. However, when you unplug them the sound from your internal speakers will be at the same volume your headphones were at. So while this does not make the audio work as well as before, at least it doesn't mute your headphones all the time.

EDIT: Only one of the headphone jacks (the one at the front) is working for me, even though I changed headphones-2 as well. No idea why.

share|improve this answer

protected by Community Jun 13 '13 at 5:47

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.