Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am running xubnutu 12.04 and I am trying to port forward my computer. The problem is that nothing seems to find the computer. The address, which ifconfig and my router says, is 192.168.0.16. The problems is that when I run network scan applications they don't find the computer, and e.g. port forwarding of 192.168.0.16 doesn't work at all. On this computer I am running both windows 7 and xubuntu, and when I run windows the computer is "visible" in the network, but when I use Linux it is not. Also, I can go to 192.168.0.16 on this local computer, but when I try to access it from another computer in the network it do not work. Might there be some driver problems or a setting?

Here is output from ifconfig:

      eth0      Link encap:Ethernet  HWaddr dc:85:de:03:4c:f9  
      inet addr:192.168.0.16  Bcast:192.168.0.255  Mask:255.255.255.0
      inet6 addr: fe80::de85:deff:fe03:4cf9/64 Scope:Link
      UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
      RX packets:6403 errors:10 dropped:0 overruns:0 frame:52167
      TX packets:5591 errors:8 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:1000 
      RX bytes:5190472 (5.1 MB)  TX bytes:1263664 (1.2 MB)
      Interrupt:17 

      lo        Link encap:Local Loopback  
      inet addr:127.0.0.1  Mask:255.0.0.0
      inet6 addr: ::1/128 Scope:Host
      UP LOOPBACK RUNNING  MTU:16436  Metric:1
      RX packets:629 errors:0 dropped:0 overruns:0 frame:0
      TX packets:629 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:0 
      RX bytes:70984 (70.9 KB)  TX bytes:70984 (70.9 KB)

output from netstat -an | grep -i listen:

    tcp        0      0 0.0.0.0:8080            0.0.0.0:*               LISTEN     
    tcp        0      0 0.0.0.0:30033           0.0.0.0:*               LISTEN     
    tcp        0      0 127.0.0.1:53            0.0.0.0:*               LISTEN     
    tcp        0      0 127.0.0.1:631           0.0.0.0:*               LISTEN     
    tcp        0      0 0.0.0.0:10011           0.0.0.0:*               LISTEN     
    unix  2      [ ACC ]     STREAM     LISTENING     10350    @/tmp/.ICE-unix/1688
    unix  2      [ ACC ]     SEQPACKET  LISTENING     7717     /run/udev/control
    unix  2      [ ACC ]     STREAM     LISTENING     9043     /tmp/ssh-NtifkVMY1635/agent.1635
    unix  2      [ ACC ]     STREAM     LISTENING     6489     @/com/ubuntu/upstart
    unix  2      [ ACC ]     STREAM     LISTENING     10351    /tmp/.ICE-unix/1688
    unix  2      [ ACC ]     STREAM     LISTENING     7834     @/org/bluez/audio
    unix  2      [ ACC ]     STREAM     LISTENING     9795     @/tmp/.X11-unix/X0
    unix  2      [ ACC ]     STREAM     LISTENING     8305     /var/run/acpid.socket
    unix  2      [ ACC ]     STREAM     LISTENING     6775     /var/run/dbus/system_bus_socket
    unix  2      [ ACC ]     STREAM     LISTENING     10312    @/tmp/dbus-lA8aAc2ipV
    unix  2      [ ACC ]     STREAM     LISTENING     7831     /var/run/sdp
    unix  2      [ ACC ]     STREAM     LISTENING     9796     /tmp/.X11-unix/X0
    unix  2      [ ACC ]     STREAM     LISTENING     6836     /var/run/avahi-daemon/socket
    unix  2      [ ACC ]     STREAM     LISTENING     11298    /home/euhiemf/.pulse/108bb33d36ea8478da5401810000000a-runtime/native
    unix  2      [ ACC ]     STREAM     LISTENING     11989    /tmp/.com.google.Chrome.iDv2kF/SingletonSocket
    unix  2      [ ACC ]     STREAM     LISTENING     8968     /tmp/keyring-EqigaB/control
    unix  2      [ ACC ]     STREAM     LISTENING     6857     /var/run/cups/cups.sock

from ufw status verbose:

Status: inactive

I don't have any other firewalls running as far as I am concerned, except maybe iptables or something?

from iptables --list-rules:

-P INPUT ACCEPT
-P FORWARD ACCEPT
-P OUTPUT ACCEPT

What I have running, which I am trying to access is python -m SimpleHTTPServer 8080. When I go to 192.168.0.16:8080 in my web-browser on this local computer it works, but when I try going to that same address on my other computer or my phone, which are all connected to the same network, it doesn't work. The server isn't found, and I do not get any output in the console from where I have the python server running. It's the same problem with any other port, and also with other applications. I can't connect to my teamspeak server from any other computer than this specific computer.

EDIT: Something interesting that I just discovered. I cant browse to my routers config page, 192.168.0.1, from this specific computer but I am connected to the Internet and to the network and to the router. However, I can go to 192.168.0.1 from all my other devices which are all connected to the same router, and the same network!

EDIT2: The router config page (192.168.0.1) now seems to work, but the other problems remains.

share|improve this question
    
Please edit your post to include the output of ifconfig. Port-forwarding is not necessary on internal (LAN) connections unless you are trying to internally forward an incoming port to an alternate port assignment –  douggro May 10 '13 at 19:13
    
Please edit your post by adding the output of sudo ufw status verbose. How are you trying to access your Ubuntu computer from other computers in the same network? –  Daniel Yuste Aroca May 10 '13 at 22:06
    
Thanks for adding the ifconfig output - it looks mostly normal. Try netstat -an | grep -i listen which will output all services listening for input. You're looking for the entries leading with tcp - add them to your post. –  douggro May 10 '13 at 23:29
    
Okay, it's listening on 8080. Does the server have a hostname? If so, try 'hostname.local:8080' and see if that works. –  douggro May 11 '13 at 20:48
    
@douggro That is cool! Didnt know you could do that, however it gave the same result as 192.168.0.16:8080. I could connect and it worked fine on this local computer, but not on any of the other devices that are connected to the same network. –  user1105047 May 11 '13 at 21:42
show 3 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.