Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have installed Ubuntu with dual boot to a preinstalled windows 8 on a Lenovo E-135. I disabled fast start in windows 8 before installation and shrank the partition to give place for Ubuntu. All went well and the installer went on very smoothly. After restart Ubuntu booted perfectly.....

And then I tried to restart to boot into windows 8 but no entries suggestion any windows partition. I restarted into Ubuntu and ran Boot repair. All went well and after the next reboot a lot of entries were present suggesting some could be the windows entry.. But nothing allowed Windows 8 to start.

Some options reported that they were forbidden for secure-boot and others reported that a file was missing.

I looked at the Boot repair report but I can not understand what it tells me. So what shall I do to make Windows 8 start also??

Here is the paste file first part

Boot Info Script e7fc706 + Boot-Repair extra info      [Boot-Info 31Jan2013]


============================= Boot Info Summary: ===============================

 => No boot loader is installed in the MBR of /dev/sda.

sda1: __________________________________________________________________________

    File system:       ntfs
    Boot sector type:  Windows 8/2012: NTFS
    Boot sector info:  No errors found in the Boot Parameter Block.
    Operating System:  
    Boot files:        

sda2: __________________________________________________________________________

    File system:       vfat
    Boot sector type:  Windows 8/2012: FAT32
    Boot sector info:  No errors found in the Boot Parameter Block.
    Operating System:  
    Boot files:        /EFI/Boot/bkpbootx64.efi /EFI/Boot/bootx64.efi 
                       /EFI/ubuntu/grubx64.efi /EFI/ubuntu/shimx64.efi 
                       /EFI/Lenovo/Boot/bootmgfw.efi 
                       /EFI/Lenovo/Boot/bootmgr.efi 
                       /EFI/Lenovo/Boot/memtest.efi 
                       /EFI/Microsoft/Boot/bkpbootmgfw.efi 
                       /EFI/Microsoft/Boot/bootmgfw.efi 
                       /EFI/Microsoft/Boot/bootmgr.efi 
                       /EFI/Microsoft/Boot/bootx64.efi 
                       /EFI/Microsoft/Boot/memtest.efi

sda3: __________________________________________________________________________

    File system:       
    Boot sector type:  -
    Boot sector info: 
    Mounting failed:   mount: unknown filesystem type ''

sda4: __________________________________________________________________________

    File system:       ntfs
    Boot sector type:  Windows 8/2012: NTFS
    Boot sector info:  No errors found in the Boot Parameter Block.
    Operating System:  Windows 8
    Boot files:        /bootmgr /Boot/BCD /Windows/System32/winload.exe

sda5: __________________________________________________________________________

    File system:       ntfs
    Boot sector type:  Windows 8/2012: NTFS
    Boot sector info:  No errors found in the Boot Parameter Block.
    Operating System:  
    Boot files:        

sda6: __________________________________________________________________________

    File system:       ext4
    Boot sector type:  -
    Boot sector info: 
    Operating System:  Ubuntu 13.04 
    Boot files:        /boot/grub/grub.cfg /etc/fstab

sda7: __________________________________________________________________________

    File system:       swap
    Boot sector type:  -
    Boot sector info: 

============================ Drive/Partition Info: =============================

Drive: sda _____________________________________________________________________

Disk /dev/sda: 500.1 GB, 500107862016 bytes
255 heads, 63 sectors/track, 60801 cylinders, total 976773168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes

Partition  Boot  Start Sector    End Sector  # of Sectors  Id System

/dev/sda1                   1   976,773,167   976,773,167  ee GPT


GUID Partition Table detected.

Partition    Start Sector    End Sector  # of Sectors System
/dev/sda1           2,048     2,050,047     2,048,000 Windows Recovery Environment (Windows)
/dev/sda2       2,050,048     2,582,527       532,480 EFI System partition
/dev/sda3       2,582,528     2,844,671       262,144 Microsoft Reserved Partition (Windows)
/dev/sda4       2,844,672   475,482,111   472,637,440 Data partition (Windows/Linux)
/dev/sda5     944,373,760   976,773,119    32,399,360 Windows Recovery Environment (Windows)
/dev/sda6     475,482,112   936,921,087   461,438,976 Data partition (Windows/Linux)
/dev/sda7     936,921,088   944,373,759     7,452,672 Swap partition (Linux)

"blkid" output: ________________________________________________________________

Device           UUID                                   TYPE       LABEL

/dev/sda1        66D6ECC9D6EC9A97                       ntfs       WINRE_DRV
/dev/sda2        6AF0-0738                              vfat       SYSTEM_DRV
/dev/sda4        C436F52136F51560                       ntfs       Windows8_OS
/dev/sda5        F238E5D638E599BD                       ntfs       Lenovo_Recovery
/dev/sda6        7686bd41-5732-4917-9853-604e7ef61127   ext4       
/dev/sda7        2d8b17e7-d16c-4361-98bb-7445edccf581   swap       

================================ Mount points: =================================

Device           Mount_Point              Type       Options

/dev/sda6        /                        ext4       (rw,errors=remount-ro)
share|improve this question
    
I did disable secure boot in the boot option and then everything works, but is it really necessary to do that??? –  user154486 May 10 '13 at 17:35
    
Why don't you post the full boot-repair log or a pastebin link to it? –  bcbc May 11 '13 at 7:26
add comment

2 Answers 2

I had issues with BIOS-set SecureBoot disallowing entry into my Windows 8 partitions - but, it appears that I've been able to reenable it now after getting GRUB finalized and Ubuntu/Windows setup the way I like.

Some appear to point to SecureBoot being problematic, depending on its original setting upon installation of Ubuntu to start with, see these links: https://help.ubuntu.com/community/UEFI#SecureBoot https://wiki.ubuntu.com/SecurityTeam/SecureBoot

share|improve this answer
    
FWIW, through version 13.04, Ubuntu seems to be shipping with the older shim 0.1, whereas shim 0.2 is the current version. This could be why Ubuntu users seem to be having so many problems with Secure Boot. It's possible to upgrade by using a shim binary from Fedora, OpenSUSE, or Matthew Garrett (shim's creator), but then you'll need to add Ubuntu's public key using a tool called MokManager. See my Web page on Secure Boot for details. It's probably easier to disable Secure Boot than to jump through these hoops. –  Rod Smith May 11 '13 at 0:27
add comment

I have Lenovo Z585 with windows 8 on it.I gone uefi help on ubuntu and used boot repair.I was successful to boot into Ubuntu and Windows 8 Both for me the working boot entries were

/EFI/Microsoft/Boot/bkpbootmgfw.efi 
/EFI/Boot/bkpbootx64.efi

also I got boot info created successfully from Boot Repair you can view it from here http://paste2.org/PyBVmVtW
This is my /etc/grub.d/10_linux file created by boot repair

      ### BEGIN /etc/grub.d/10_linux ###
function gfxmode {
    set gfxpayload="$1"
    if [ "$1" = "keep" ]; then
        set vt_handoff=vt.handoff=7
    else
        set vt_handoff=
    fi
}
if [ ${recordfail} != 1 ]; then
  if [ -e ${prefix}/gfxblacklist.txt ]; then
    if hwmatch ${prefix}/gfxblacklist.txt 3; then
      if [ ${match} = 0 ]; then
        set linux_gfx_mode=keep
      else
        set linux_gfx_mode=text
      fi
    else
      set linux_gfx_mode=text
    fi
  else
    set linux_gfx_mode=keep
  fi
else
  set linux_gfx_mode=text
fi
export linux_gfx_mode
if [ "$linux_gfx_mode" != "text" ]; then load_video; fi
menuentry 'Linux Mint 15 MATE 64-bit, 3.8.0-19-generic (/dev/sda12)' --class gnu-linux --class gnu --class os {
    recordfail
    gfxmode $linux_gfx_mode
    insmod gzio
    insmod part_gpt
    insmod ext2
    set root='hd0,gpt12'
    if [ x$feature_platform_search_hint = xy ]; then
      search --no-floppy --fs-uuid --set=root --hint-bios=hd0,gpt12 --hint-efi=hd0,gpt12 --hint-baremetal=ahci0,gpt12  83a13fa7-97c3-4781-b9d2-54eca6256dd0
    else
      search --no-floppy --fs-uuid --set=root 83a13fa7-97c3-4781-b9d2-54eca6256dd0
    fi
    linux   /vmlinuz-3.8.0-19-generic root=UUID=7191f35a-8155-47d2-b468-993e813487b4 ro   
    initrd  /initrd.img-3.8.0-19-generic
}
menuentry 'Linux Mint 15 MATE 64-bit, 3.8.0-19-generic (/dev/sda12) -- recovery mode' --class gnu-linux --class gnu --class os {
    recordfail
    insmod gzio
    insmod part_gpt
    insmod ext2
    set root='hd0,gpt12'
    if [ x$feature_platform_search_hint = xy ]; then
      search --no-floppy --fs-uuid --set=root --hint-bios=hd0,gpt12 --hint-efi=hd0,gpt12 --hint-baremetal=ahci0,gpt12  83a13fa7-97c3-4781-b9d2-54eca6256dd0
    else
      search --no-floppy --fs-uuid --set=root 83a13fa7-97c3-4781-b9d2-54eca6256dd0
    fi
    echo    'Loading Linux 3.8.0-19-generic ...'
    linux   /vmlinuz-3.8.0-19-generic root=UUID=7191f35a-8155-47d2-b468-993e813487b4 ro recovery nomodeset 
    echo    'Loading initial ramdisk ...'
    initrd  /initrd.img-3.8.0-19-generic
}
### END /etc/grub.d/10_linux ###

This is my /etc/grub.d/25_custom file created by boot repair

    ### BEGIN /etc/grub.d/25_custom ###

menuentry "efi/EFI/Boot/bootx64.efi" {
search --fs-uuid --no-floppy --set=root 83a13fa7-97c3-4781-b9d2-54eca6256dd0
chainloader (${root})/efi/EFI/Boot/bootx64.efi
}

menuentry "Windows UEFI recovery bkpbootmgfw.efi" {
search --fs-uuid --no-floppy --set=root FAC9-363B
chainloader (${root})/EFI/Microsoft/Boot/bkpbootmgfw.efi
}

menuentry "Windows Boot UEFI recovery" {
search --fs-uuid --no-floppy --set=root FAC9-363B
chainloader (${root})/EFI/Boot/bkpbootx64.efi
}

menuentry "Windows UEFI recovery LrsBootmgr.efi" {
search --fs-uuid --no-floppy --set=root 38C9-8F9B
chainloader (${root})/EFI/Microsoft/Boot/LrsBootmgr.efi
}

menuentry "Windows Boot UEFI recovery bkpbootx64.efi" {
search --fs-uuid --no-floppy --set=root 38C9-8F9B
chainloader (${root})/EFI/Boot/bkpbootx64.efi
}
### END /etc/grub.d/25_custom ###

Hope this helps You !!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.