Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I had ubuntu for 3 years( since version 11). Every version I had, had the Intel Graphics bug in it's kernel - randomly freezing mouse. I fixed this problem using "echo N> /sys/module/drm_kms_helper/parameters/poll" (changing it from Y to N), as described in http://souriguha.wordpress.com/2011/03/08/how-to-solve-problem-with-thinkpadkslowd-kworker-on-linux-kernel-2-35-2-36/ .

I upgraded to version 13, and unfortunately this doesn't work (there is no /etc/modprobe.d/local.conf), I searched the web and tried adding the command above to /etc/rc.local, when I check the param it seem to be set to N, but still didn't solve the problem, so tried setting it to 0, and checked it, it turns back to Y somehow. The freezes still occurs :(

My kernel version is: Linux *-ThinkPad-T400 3.8.0-19-generic #30-Ubuntu SMP Wed May 1 16:35:23 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux.

What should I do? And on what version this bug will be fixed (It's really annoying since v11)?

Btw: If someone could explain to me what is the relation between polling and the mouse (I think it's the whole screen)?!

share|improve this question

1 Answer 1

This fixed it for me on Ubuntu 13.04:

sudo modprobe drm_kms_helper
echo N> /sys/module/drm_kms_helper/parameters/poll

Apparently the drm_kms_helper module isn't loaded by default on 13.04? You may have to load it in your /etc/modprobe.d/ and then sett the poll parameter.

share|improve this answer
    
I just moved to openSuse with KDE and It seems to be a lot better than Ubuntu with KDE (more stable and bug-less), and I don't have this issue with drm_kms_helper. But, Thanx a lot man :) –  SomeKidding Guy May 29 '13 at 13:28

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.