Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

This question already has an answer here:

I know there's a few relevant questions answered but when I try to format it through disk utility the only answer I get is:

"Error synchrinizing after initial wipe: Timed out waiting for object (udisks-error-quark,0)

I'm new to Linux, had no problem with Debian, Ubuntu seemed even friendlier in the start but seems I can't do a simple thing like formatting a usb stick. I know that some of you will tell me to download Gparted or something but since Ubuntu by default has a disk utility that does the job it should work, shouldn't it?

Is something wrong with my dash? Is it something fixable or something missing? When a utility is already there it should work or at least know why it doesn't. Installing and using something else is not a good solution. Formatting is so simple and easy on Debian...

share|improve this question

marked as duplicate by Eric Carvalho, Raja, user68186, Thomas Ward, Flimm May 10 '13 at 16:50

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

you can try gparted – GM-Script-Writer-62850 May 10 '13 at 8:50
Possible duplicate How to format a USB or external drive? – Warren Hill May 10 '13 at 8:53
This is a bug report, and hence off-topic. Hopefully, the linked possible duplicate question is useful to you. – Flimm May 10 '13 at 16:49

This has been reported as a bug, you can check it out here -

you can mention that this bug affects you (at the aforementioned site, i.e.), it'll help give the bug greater attention.

you can always use gparted for formatting a disk. to get gparted, you can use the software centre or enter the following command in the terminal

sudo apt-get install gparted

choose your device, unmount it and then right-click to open a menu. within the menu you'll find a 'format to' option, use that to format it to whichever file format you wish to use, and click on apply.

That should work out perfectly.

share|improve this answer
Thank you Projjol, this is a bug as you mentioned which is reported and confirmed since Oct'12 but it still exists at 13.04 as I read... Nice going ubuntu developers! – Lazaros May 10 '13 at 11:27
Indeed, it's been on Ubuntu's bug list for a while and it affects 72 people, but no major development on that front has taken place. I guess, if more and more users confirm that they're affected by it, it'll get more attention. – Projjol May 10 '13 at 13:23

Not the answer you're looking for? Browse other questions tagged or ask your own question.