Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have Ubuntu 10.04 install DELL R710 server

I have configured the network bonding using the below steps

sudo apt-get install ifenslave
-------------------------------------------
vi /etc/network/interfaces
# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
auto eth0
 iface eth0 inet manual
   bond-master bond0
 auto eth1
 iface eth1 inet manual
   bond-master bond0
 auto bond0
 iface bond0 inet static
   address 172.24.1.10
   gateway 172.24.1.1
   netmask 255.255.255.0
   dns-nameservers 172.24.1.50
   dns-search xxx.xxx
   bond-mode balance-rr
   bond-miimon 100
   bond-lacp-rate 1
   bond-slaves none
----------------------------------------------------------
cat /proc/net/bonding/bond0
Ethernet Channel Bonding Driver: v3.5.0 (November 4, 2008)
Bonding Mode: load balancing (round-robin)
MII Status: up
MII Polling Interval (ms): 100
Up Delay (ms): 0
Down Delay (ms): 0
Slave Interface: eth0
MII Status: up
Link Failure Count: 0
Permanent HW addr: xx:xx:xx:xx:xx:xx
Slave Interface: eth1
MII Status: up
Link Failure Count: 0
Permanent HW addr: xx:xx:xx:xx:xx:yy
----------------------------------------------------------------
 **its not showing the bonding speed .**
---------------------------------------------------------
ethtool eth0
Settings for eth0:
        Supported ports: [ TP ]
        Supported link modes:   10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Full
        Supports auto-negotiation: Yes
        Advertised link modes:  10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Full
        Advertised pause frame use: No
        Advertised auto-negotiation: Yes
        Link partner advertised link modes:  Not reported
        Link partner advertised pause frame use: No
        Link partner advertised auto-negotiation: No
        Speed: 1000Mb/s
        Duplex: Full
        Port: Twisted Pair
        PHYAD: 1
        Transceiver: internal
        Auto-negotiation: on
        MDI-X: Unknown
        Supports Wake-on: g
        Wake-on: g
        Link detected: yes
 ethtool eth1
Settings for eth1:
        Supported ports: [ TP ]
        Supported link modes:   10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Full
        Supports auto-negotiation: Yes
        Advertised link modes:  10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Full
        Advertised pause frame use: No
        Advertised auto-negotiation: Yes
        Link partner advertised link modes:  Not reported
        Link partner advertised pause frame use: No
        Link partner advertised auto-negotiation: No
        Speed: 1000Mb/s
        Duplex: Full
        Port: Twisted Pair
        PHYAD: 1
        Transceiver: internal
        Auto-negotiation: on
        MDI-X: Unknown
        Supports Wake-on: g
        Wake-on: g
        Link detected: yes

both network card speed is 1000MBPS. How do I check the bond0 network speed.

share|improve this question

1 Answer 1

It's completely related to your bonding strategy.. that speed only shows the maximum connection speed between network adapters in local network.and most of the time it's not true!

Based on bond-mode you selected within /etc/network/interfaces and description of balance-rr in ubuntu documents ,this mode is for Transmit packets in sequential order from the first available slave through the last. This mode provides load balancing and fault tolerance. It depends on the way you request packets and accessibility of each interface or route to that point in network.take a look at this documentation .

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.