Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My wireless card won't connect to the network on system boot on Ubuntu 13.04 64bit (server).

Below is my system info:

/etc/netwrok/interfaces

# WiFi
auto wlan0
iface wlan0 inet dhcp
wpa-ssid myssid
wpa-psk  ssidpass

uname -r

3.8.0-19-generic

lsusb

Bus 001 Device 002: ID 0b05:1784 ASUSTek Computer, Inc. USB-N13 802.11n Network Adapter (rev. A1) [Ralink RT3072]

It connects just fine if I run the following command:

service networking restart

Could you point me to a direction on how to troubleshoot this?

Edit 1:

Syslog (records related to wlan0 right after system reboot:

May 10 21:55:35 localhost kernel: [    6.503790] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
May 10 21:55:37 localhost dhclient: DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 4 (xid=0x62d88386)
May 10 21:55:41 localhost dhclient: DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 7 (xid=0x62d88386)
May 10 21:55:48 localhost dhclient: DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 14 (xid=0x62d88386)
May 10 21:56:02 localhost dhclient: DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 9 (xid=0x62d88386)
May 10 21:56:11 localhost dhclient: DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 17 (xid=0x62d88386)
May 10 21:56:28 localhost dhclient: DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 18 (xid=0x62d88386)
May 10 21:56:46 localhost dhclient: DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 10 (xid=0x62d88386)
May 10 21:56:56 localhost dhclient: DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 16 (xid=0x62d88386)
May 10 21:57:13 localhost dhclient: DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 18 (xid=0x62d88386)
May 10 21:57:31 localhost dhclient: DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 19 (xid=0x62d88386)
May 10 21:57:50 localhost dhclient: DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 12 (xid=0x62d88386)
May 10 21:58:02 localhost dhclient: DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 19 (xid=0x62d88386)
May 10 21:58:21 localhost dhclient: DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 15 (xid=0x62d88386)
May 10 21:58:36 localhost dhclient: DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 18 (xid=0x62d88386)
May 10 21:58:54 localhost dhclient: DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 15 (xid=0x62d88386)
May 10 21:59:09 localhost dhclient: DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 17 (xid=0x62d88386)

I also did dmesg | grep wlan0 and only got one line (see below):

[    6.391856] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready    
share|improve this question
    
Do you get any crash reports when enabling bug reporting? wiki.ubuntu.com/Apport –  NoBugs May 10 '13 at 2:30
    
Please also run sudo tail /var/log/syslog and dmesg look for anything that has to do with wireless and post it here. –  Freedom_Ben May 10 '13 at 2:55
    
@NoBugs: I enabled Apport and rebooted the station but it looks like no crash log was created (no /var/crash was created) –  Timka May 11 '13 at 2:22
    
@Freedom_Ben, I updated my post with extra information. I did change my router recently.maybe it has something to do with it... –  Timka May 11 '13 at 2:44
    
@Timka Does this occur with any other routers or just your new one? If the latter, what make/model is it? –  Freedom_Ben May 12 '13 at 3:39

1 Answer 1

By downgrading my Ubuntu box to version 12.04 I was able to fix the issue.

Successfully tested with multiple reboots.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.